Security advisory
An issue was discovered in libraries/common.inc.php in phpMyAdmin 4.0 before 4.0.10.20, 4.4.x, 4.6.x, and 4.7.0 prereleases. The restrictions caused by $cfg['Servers'][$i]['AllowNoPassword'] = false are bypassed under certain PHP versions (e.g., version 5). This can allow the login of users who have no password set even if the administrator has set $cfg['Servers'][$i]['AllowNoPassword'] to false (which is also the default). This occurs because some implementations of the PHP substr function return false when given '' as the first argument.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2017-18264
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 05:12 UTC · Revision 1
Source evidence
An issue was discovered in libraries/common.inc.php in phpMyAdmin 4.0 before 4.0.10.20, 4.4.x, 4.6.x, and 4.7.0 prereleases. The restrictions caused by $cfg['Servers'][$i]['AllowNoPassword'] = false are bypassed under certain PHP versions (e.g., version 5). This can allow the login of users who have no password set even if the administrator has set $cfg['Servers'][$i]['AllowNoPassword'] to false (which is also the default). This occurs because some implementations of the PHP substr function return false when given '' as the first argument.
osv:CVE-2017-18264
Complete source record
{
"id": "8e832af576077755f314a2029dae8b201c24ff3362aa293850847f2ba2dcd269",
"url": "https://osv.dev/vulnerability/CVE-2017-18264",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2017-18264",
"summary": "An issue was discovered in libraries/common.inc.php in phpMyAdmin 4.0 before 4.0.10.20, 4.4.x, 4.6.x, and 4.7.0 prereleases. The restrictions caused by $cfg['Servers'][$i]['AllowNoPassword'] = false are bypassed under certain PHP versions (e.g., version 5). This can allow the login of users who have no password set even if the administrator has set $cfg['Servers'][$i]['AllowNoPassword'] to false (which is also the default). This occurs because some implementations of the PHP substr function return false when given '' as the first argument.",
"evidence": "osv:CVE-2017-18264",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2017-18264",
"aliases": [
"CVE-2017-18264",
"GHSA-5868-g58j-vrj5"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/phpmyadmin/phpmyadmin",
"type": "GIT",
"events": [
{
"introduced": "6da64cc3b2ba4439574f914f51e161645375be96"
},
{
"fixed": "9a9a6ab709eb6b1b2e82b7a15851ae93a31e9e45"
},
{
"introduced": "1fe735d098d82ad79500eab04c4d25ba8fe25a24"
},
{
"last_affected": "fbd634d4c1d668e77ad15cdb38c4a85db5c75002"
},
{
"introduced": "37b38431d167915675fc8ab512470528147e72de"
},
{
"last_affected": "c812bcd4112c3d44e6e6bc72e710b9935c6aa9d3"
},
{
"introduced": "62c6e73cc5601ecd6cf839874c038a991c7b5b97"
},
{
"last_affected": "507f335777aa82c16f6fcf691a4e7b3e4b7e98ce"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:phpmyadmin:phpmyadmin:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "4.0.0"
},
{
"fixed": "4.0.10.20"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:phpmyadmin:phpmyadmin:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "4.4.0"
},
{
"last_affected": "4.4.15.10"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:phpmyadmin:phpmyadmin:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "4.6.0"
},
{
"last_affected": "4.6.6"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:phpmyadmin:phpmyadmin:4.7.0:beta1:*:*:*:*:*:*",
"range": [
{
"introduced": "4.7.0-beta1"
},
{
"last_affected": "4.7.0-beta1"
}
],
"source": "CPE_STRING"
},
{
"cpe": "cpe:2.3:a:phpmyadmin:phpmyadmin:4.7.0:rc1:*:*:*:*:*:*",
"range": [
{
"introduced": "4.7.0-rc1"
},
{
"last_affected": "4.7.0-rc1"
}
],
"source": "CPE_STRING"
}
]
}
}
],
"versions": [
"4.7.0-beta1",
"4.7.0-rc1",
"RELEASE_4_7_0RC1",
"RELEASE_4_7_0BETA1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2017-18264.json"
}
}
],
"modified": "2026-10-24T10:30:25.700310496Z",
"provider": "osv",
"references": [
"https://lists.debian.org/debian-lts-announce/2018/07/msg00006.html",
"https://www.phpmyadmin.net/security/PMASA-2017-8/"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*"
],
"vendor_product": "debian:debian_linux",
"extracted_events": [
{
"range": [
{
"introduced": "8.0"
},
{
"last_affected": "8.0"
}
],
"source": "CPE_STRING"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2017-18264",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 431428,
"published_at": "2018-05-01T17:29:00.237+00:00"
}