ckeditor, ckeditor3 — security advisory
CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. A vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4 prior to version 4.18.0. The vulnerability allows someone to inject malformed HTML bypassing content sanitization, which could result in executing JavaScript code. This problem has been patched in version 4.18.0. There are currently no known workarounds.
- Products
- ckeditor, ckeditor3
- Affected versions
- 3.6.6.1+dfsg-7
- Fixed versions
- 4.19.0+dfsg-1
- CVEs
- CVE-2022-24728
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 14:36 UTC · Revision 1
Source evidence
CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. A vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4 prior to version 4.18.0. The vulnerability allows someone to inject malformed HTML bypassing content sanitization, which could result in executing JavaScript code. This problem has been patched in version 4.18.0. There are currently no known workarounds.
osv:DEBIAN-CVE-2022-24728
ckeditor
Fixed versions: 4.19.0+dfsg-1
ckeditor3
Fixed versions: Not specified
Complete source record
{
"id": "bc4d325c9c75602e45513382786192dbf63e8807aff0e95e87b34e0459d4b694",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-24728",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2022-24728",
"summary": "CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. A vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4 prior to version 4.18.0. The vulnerability allows someone to inject malformed HTML bypassing content sanitization, which could result in executing JavaScript code. This problem has been patched in version 4.18.0. There are currently no known workarounds.",
"evidence": "osv:DEBIAN-CVE-2022-24728",
"products": [
{
"name": {
"value": "ckeditor",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4.19.0+dfsg-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "ckeditor3",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "3.6.6.1+dfsg-7",
"evidence": "/affected/1/versions"
}
]
}
],
"severity": "medium",
"structured": {
"id": "DEBIAN-CVE-2022-24728",
"aliases": [
"DEBIAN-CVE-2022-24728"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.19.0+dfsg-1"
}
]
}
],
"package": {
"name": "ckeditor",
"purl": "pkg:deb/debian/ckeditor?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-24728.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "ckeditor3",
"purl": "pkg:deb/debian/ckeditor3?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"3.6.6.1+dfsg-7"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-24728.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-15T08:01:04.216038939Z",
"provider": "osv",
"upstream": [
"CVE-2022-24728"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2022-24728"
]
},
"related_cves": [
{
"value": "CVE-2022-24728",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 322778,
"published_at": "2022-03-16T16:15:10.907+00:00"
}