CriticalFix available
xmlbeans — security advisory
The XML parsers used by XMLBeans up to version 2.6.0 did not set the properties needed to protect the user from malicious XML input. Vulnerabilities include possibilities for XML Entity Expansion attacks. Affects XMLBeans up to and including v2.6.0.
- Products
- xmlbeans
- Affected versions
- Not specified
- Fixed versions
- 3.0.2-1
- CVEs
- CVE-2021-23926
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 00:20 UTC · Revision 1
Source evidence
The XML parsers used by XMLBeans up to version 2.6.0 did not set the properties needed to protect the user from malicious XML input. Vulnerabilities include possibilities for XML Entity Expansion attacks. Affects XMLBeans up to and including v2.6.0.
osv:DEBIAN-CVE-2021-23926
xmlbeans
Fixed versions: 3.0.2-1
xmlbeans
Fixed versions: 3.0.2-1
xmlbeans
Fixed versions: 3.0.2-1
Complete source record
{
"id": "81d11d10b556ef4202636babf80623ea1b6f0ddb7f527bdc8537a4aab02c5715",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2021-23926",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2021-23926",
"summary": "The XML parsers used by XMLBeans up to version 2.6.0 did not set the properties needed to protect the user from malicious XML input. Vulnerabilities include possibilities for XML Entity Expansion attacks. Affects XMLBeans up to and including v2.6.0.",
"evidence": "osv:DEBIAN-CVE-2021-23926",
"products": [
{
"name": {
"value": "xmlbeans",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.0.2-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "xmlbeans",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.0.2-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "xmlbeans",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.0.2-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "critical",
"structured": {
"id": "DEBIAN-CVE-2021-23926",
"aliases": [
"DEBIAN-CVE-2021-23926"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.0.2-1"
}
]
}
],
"package": {
"name": "xmlbeans",
"purl": "pkg:deb/debian/xmlbeans?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-23926.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.0.2-1"
}
]
}
],
"package": {
"name": "xmlbeans",
"purl": "pkg:deb/debian/xmlbeans?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-23926.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.0.2-1"
}
]
}
],
"package": {
"name": "xmlbeans",
"purl": "pkg:deb/debian/xmlbeans?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-23926.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T18:03:12.050854007Z",
"provider": "osv",
"upstream": [
"CVE-2021-23926"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2021-23926"
]
},
"related_cves": [
{
"value": "CVE-2021-23926",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 420783,
"published_at": "2021-01-14T15:15:13.337+00:00"
}