Medium
Security advisory
In Kaminari before 1.2.1, there is a vulnerability that would allow an attacker to inject arbitrary code into pages with pagination links. This has been fixed in 1.2.1.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2020-11082
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 10:49 UTC · Revision 1
Source evidence
In Kaminari before 1.2.1, there is a vulnerability that would allow an attacker to inject arbitrary code into pages with pagination links. This has been fixed in 1.2.1.
osv:CVE-2020-11082
Complete source record
{
"id": "395b3043d47dcfa4e21e93232c1b23a0a41477aa7f8ee16c1f297830a4acf09e",
"url": "https://osv.dev/vulnerability/CVE-2020-11082",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2020-11082",
"summary": "In Kaminari before 1.2.1, there is a vulnerability that would allow an attacker to inject arbitrary code into pages with pagination links. This has been fixed in 1.2.1.",
"evidence": "osv:CVE-2020-11082",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2020-11082",
"aliases": [
"CVE-2020-11082",
"GHSA-r5jw-62xg-j433"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/kaminari/kaminari",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "ab8b1118bd721edc520a7cd32e0a72dc6d0d3608"
},
{
"fixed": "8dd52a1aed3d2fa2835d836de23fc0d8c4ff5db8"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:kaminari_project:kaminari:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.2.1"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "8dd52a1aed3d2fa2835d836de23fc0d8c4ff5db8"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"v1.2.0",
"v1.1.1",
"v1.1.0",
"v1.0.1",
"v1.0.0",
"v1.0.0.rc1",
"v1.0.0.beta2",
"v1.0.0.beta1",
"v0.15.1",
"v0.15.0",
"v0.14.1",
"v0.14.0",
"v0.13.0",
"v0.12.4",
"v0.12.3",
"v0.12.2",
"v0.12.1",
"v0.12.0",
"v0.11.0",
"v0.10.4",
"v0.10.3",
"v0.10.2",
"v0.10.1",
"v0.10.0",
"v0.9.13",
"v0.9.9",
"v0.9.8",
"v0.9.7",
"v0.9.6",
"v0.9.5",
"v0.9.4",
"v0.9.3",
"v0.9.2",
"v0.9.1",
"v0.9.0",
"v0.8.0",
"v0.7.0",
"v0.6.1",
"v0.6.0",
"v0.5.0",
"v0.4.0",
"v0.3.0",
"v0.2.1",
"v0.2.0",
"v0.1.0",
"show"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2020-11082.json"
}
}
],
"modified": "2026-10-20T10:51:46.156509806Z",
"provider": "osv",
"references": [
"https://github.com/kaminari/kaminari/security/advisories/GHSA-r5jw-62xg-j433",
"https://lists.debian.org/debian-lts-announce/2021/09/msg00011.html",
"https://www.debian.org/security/2021/dsa-5005",
"https://github.com/github/advisory-review/pull/1020",
"https://github.com/kaminari/kaminari/commit/8dd52a1aed3d2fa2835d836de23fc0d8c4ff5db8"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*",
"cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*"
],
"vendor_product": "debian:debian_linux",
"extracted_events": [
{
"range": [
{
"introduced": "9.0"
},
{
"last_affected": "9.0"
},
{
"introduced": "10.0"
},
{
"last_affected": "10.0"
}
],
"source": "CPE_STRING"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2020-11082",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 382904,
"published_at": "2020-05-28T21:15:11.437+00:00"
}