multipath-tools — security advisory
multipath-tools 0.7.0 through 0.9.x before 0.9.2 allows local users to obtain root access, as exploited alone or in conjunction with CVE-2022-41973. Local users able to write to UNIX domain sockets can bypass access controls and manipulate the multipath setup. This can lead to local privilege escalation to root. This occurs because an attacker can repeat a keyword, which is mishandled because arithmetic ADD is used instead of bitwise OR.
- Products
- multipath-tools
- Affected versions
- Not specified
- Fixed versions
- 0.9.4-1
- CVEs
- CVE-2022-41974
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 15:02 UTC · Revision 1
Source evidence
multipath-tools 0.7.0 through 0.9.x before 0.9.2 allows local users to obtain root access, as exploited alone or in conjunction with CVE-2022-41973. Local users able to write to UNIX domain sockets can bypass access controls and manipulate the multipath setup. This can lead to local privilege escalation to root. This occurs because an attacker can repeat a keyword, which is mishandled because arithmetic ADD is used instead of bitwise OR.
osv:DEBIAN-CVE-2022-41974
multipath-tools
Fixed versions: 0.9.4-1
multipath-tools
Fixed versions: 0.9.4-1
multipath-tools
Fixed versions: 0.9.4-1
Complete source record
{
"id": "5679a5f673fb36845c7024a5e6768c9d9756e8dfcb77321d2636e7dab787219d",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-41974",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2022-41974",
"summary": "multipath-tools 0.7.0 through 0.9.x before 0.9.2 allows local users to obtain root access, as exploited alone or in conjunction with CVE-2022-41973. Local users able to write to UNIX domain sockets can bypass access controls and manipulate the multipath setup. This can lead to local privilege escalation to root. This occurs because an attacker can repeat a keyword, which is mishandled because arithmetic ADD is used instead of bitwise OR.",
"evidence": "osv:DEBIAN-CVE-2022-41974",
"products": [
{
"name": {
"value": "multipath-tools",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "0.9.4-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "multipath-tools",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "0.9.4-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "multipath-tools",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "0.9.4-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2022-41974",
"aliases": [
"DEBIAN-CVE-2022-41974"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.9.4-1"
}
]
}
],
"package": {
"name": "multipath-tools",
"purl": "pkg:deb/debian/multipath-tools?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-41974.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.9.4-1"
}
]
}
],
"package": {
"name": "multipath-tools",
"purl": "pkg:deb/debian/multipath-tools?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-41974.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.9.4-1"
}
]
}
],
"package": {
"name": "multipath-tools",
"purl": "pkg:deb/debian/multipath-tools?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-41974.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-15T08:02:45.128847291Z",
"provider": "osv",
"upstream": [
"CVE-2022-41974"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2022-41974"
]
},
"related_cves": [
{
"value": "CVE-2022-41974",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 324129,
"published_at": "2022-10-29T19:15:10.16+00:00"
}