Envoy vulnerable to OAuth2 credentials exploit with permanent validity
Envoy is an open source edge and service proxy designed for cloud-native applications. Prior to versions 1.27.0, 1.26.4, 1.25.9, 1.24.10, and 1.23.12, a malicious client is able to construct credentials with permanent validity in some specific scenarios. This is caused by the some rare scenarios in which HMAC payload can be always valid in OAuth2 filter's check. Versions 1.27.0, 1.26.4, 1.25.9, 1.24.10, and 1.23.12 have a fix for this issue. As a workaround, avoid wildcards/prefix domain wildcards in the host's domain configuration.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2023-35941
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 5 Nov 2026, 02:05 UTC · Revision 1
Source evidence
Envoy vulnerable to OAuth2 credentials exploit with permanent validity
core-osv · Original sourcePublished 25 Jul 2023, 17:40 UTC
Envoy is an open source edge and service proxy designed for cloud-native applications. Prior to versions 1.27.0, 1.26.4, 1.25.9, 1.24.10, and 1.23.12, a malicious client is able to construct credentials with permanent validity in some specific scenarios. This is caused by the some rare scenarios in which HMAC payload can be always valid in OAuth2 filter's check. Versions 1.27.0, 1.26.4, 1.25.9, 1.24.10, and 1.23.12 have a fix for this issue. As a workaround, avoid wildcards/prefix domain wildcards in the host's domain configuration.
osv:CVE-2023-35941
Complete source record
{
"id": "4d92a65860274c47893ccb15ddab3932915982d347bd3d46fb25181289a43f7e",
"url": "https://osv.dev/vulnerability/CVE-2023-35941",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Envoy vulnerable to OAuth2 credentials exploit with permanent validity",
"summary": "Envoy is an open source edge and service proxy designed for cloud-native applications. Prior to versions 1.27.0, 1.26.4, 1.25.9, 1.24.10, and 1.23.12, a malicious client is able to construct credentials with permanent validity in some specific scenarios. This is caused by the some rare scenarios in which HMAC payload can be always valid in OAuth2 filter's check. Versions 1.27.0, 1.26.4, 1.25.9, 1.24.10, and 1.23.12 have a fix for this issue. As a workaround, avoid wildcards/prefix domain wildcards in the host's domain configuration.",
"evidence": "osv:CVE-2023-35941",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2023-35941",
"aliases": [
"BIT-envoy-2023-35941",
"CVE-2023-35941",
"GHSA-7mhv-gr67-hq55"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/envoyproxy/envoy",
"type": "GIT",
"events": [
{
"introduced": "ce49c7f65668a22b80d1e83c35d170741bb8d46a"
},
{
"fixed": "9689bc57f80fe56dbb16a4e0d632cde5363d1811"
},
{
"introduced": "15baf56003f33a07e0ab44f82f75a660040db438"
},
{
"fixed": "5adb03f52a6399fe5a31fdb603d5009d8d59cdb9"
},
{
"introduced": "9184b84cd0dcb3a6c57eb44b177d91c70e1a0901"
},
{
"fixed": "7b2609e12147377b0420bfa4453762e377f218f3"
},
{
"introduced": "51964702956d64adcd1df6b8ea132e863fe78e74"
},
{
"fixed": "cfa32deca25ac57c2bbecdad72807a9b13493fc1"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:envoyproxy:envoy:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "1.23.0"
},
{
"fixed": "1.23.12"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:envoyproxy:envoy:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "1.24.0"
},
{
"fixed": "1.24.10"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:envoyproxy:envoy:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "1.25.0"
},
{
"fixed": "1.25.9"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:envoyproxy:envoy:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "1.26.0"
},
{
"fixed": "1.26.4"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v1.26.3",
"v1.25.8",
"v1.24.9",
"v1.23.11",
"v1.24.8",
"v1.26.2",
"v1.23.10",
"v1.25.7",
"v1.25.6",
"v1.24.7",
"v1.26.1",
"v1.23.9",
"v1.25.5",
"v1.24.6",
"v1.23.8",
"v1.26.0",
"v1.25.4",
"v1.23.7",
"v1.24.5",
"v1.25.3",
"v1.23.6",
"v1.24.4",
"v1.25.2",
"v1.23.5",
"v1.24.3",
"v1.24.2",
"v1.23.4",
"v1.25.1",
"v1.25.0",
"v1.24.1",
"v1.23.3",
"v1.23.2",
"v1.24.0",
"v1.23.1",
"v1.23.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-35941.json"
}
}
],
"modified": "2026-10-28T02:30:41.872634377Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/35xxx/CVE-2023-35941.json",
"https://github.com/envoyproxy/envoy/security/advisories/GHSA-7mhv-gr67-hq55",
"https://nvd.nist.gov/vuln/detail/CVE-2023-35941"
],
"provider_metadata": {
"cwe_ids": [
"CWE-116"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/35xxx/CVE-2023-35941.json"
}
},
"related_cves": [
{
"value": "CVE-2023-35941",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 509353,
"published_at": "2023-07-25T17:40:56.203+00:00"
}