Skip to content
Heist/ feed
Back to feed
Medium

Security advisory

Type: advisorySources: OSVCVE: CVE-2018-25104

A vulnerability was found in CoinGate Plugin up to 1.2.7 on PrestaShop. It has been rated as problematic. Affected by this issue is the function postProcess of the file modules/coingate/controllers/front/callback.php of the component Payment Handler. The manipulation leads to business logic errors. The attack may be launched remotely. Upgrading to version 1.2.8 is able to address this issue. The patch is identified as 0a3097db0aec7c5d66686c142c6abaa1e126ca16. It is recommended to upgrade the affected component.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2018-25104
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 09:51 UTC · Revision 1

Source evidence

CVE-2018-25104

core-osv · Original source

Published 17 Oct 2024, 16:15 UTC

A vulnerability was found in CoinGate Plugin up to 1.2.7 on PrestaShop. It has been rated as problematic. Affected by this issue is the function postProcess of the file modules/coingate/controllers/front/callback.php of the component Payment Handler. The manipulation leads to business logic errors. The attack may be launched remotely. Upgrading to version 1.2.8 is able to address this issue. The patch is identified as 0a3097db0aec7c5d66686c142c6abaa1e126ca16. It is recommended to upgrade the affected component.

osv:CVE-2018-25104
Complete source record
{
  "id": "47769fb30fe949e92127c7bae209556f73a5e6038939a8ad9ed225f9de401c2f",
  "url": "https://osv.dev/vulnerability/CVE-2018-25104",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2018-25104",
    "summary": "A vulnerability was found in CoinGate Plugin up to 1.2.7 on PrestaShop. It has been rated as problematic. Affected by this issue is the function postProcess of the file modules/coingate/controllers/front/callback.php of the component Payment Handler. The manipulation leads to business logic errors. The attack may be launched remotely. Upgrading to version 1.2.8 is able to address this issue. The patch is identified as 0a3097db0aec7c5d66686c142c6abaa1e126ca16. It is recommended to upgrade the affected component.",
    "evidence": "osv:CVE-2018-25104",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2018-25104",
      "aliases": [
        "CVE-2018-25104"
      ],
      "metrics": [
        {
          "type": "CVSS_V4",
          "score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/coingate/prestashop-plugin",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "last_affected": "373681b746f328d23a7f22dd71a799b1a1a81e96"
                },
                {
                  "fixed": "0a3097db0aec7c5d66686c142c6abaa1e126ca16"
                },
                {
                  "fixed": "43c19629661066ccd56ea22ef541133d4b939714"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "last_affected": "1.2.7"
                      }
                    ],
                    "source": "DESCRIPTION"
                  },
                  {
                    "range": [
                      {
                        "fixed": "0a3097db0aec7c5d66686c142c6abaa1e126ca16"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  },
                  {
                    "range": [
                      {
                        "fixed": "43c19629661066ccd56ea22ef541133d4b939714"
                      }
                    ],
                    "source": "REFERENCES_TAG",
                    "original_tag": "v1.2.8"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v1.2.7",
            "v1.2.6",
            "v1.2.5",
            "v1.2.4",
            "v1.2.3",
            "v1.2.2",
            "v1.2.1",
            "v1.1.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-25104.json"
          }
        }
      ],
      "modified": "2026-10-20T10:48:09.835095446Z",
      "provider": "osv",
      "references": [
        "https://github.com/coingate/prestashop-plugin/releases/tag/v1.2.8",
        "https://vuldb.com/?ctiid.280358",
        "https://vuldb.com/?id.280358",
        "https://github.com/coingate/prestashop-plugin/commit/0a3097db0aec7c5d66686c142c6abaa1e126ca16"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2018-25104",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 380102,
  "published_at": "2024-10-17T16:15:03.207+00:00"
}