Security advisory
Discourse is an open-source discussion platform. In Discourse versions 2.7.5 and prior, parsing and rendering of YouTube Oneboxes can be susceptible to XSS attacks. This vulnerability only affects sites which have modified or disabled Discourse's default Content Security Policy. The issue is patched in `stable` version 2.7.6, `beta` version 2.8.0.beta3, and `tests-passed` version 2.8.0.beta3. As a workaround, ensure that the Content Security Policy is enabled, and has not been modified in a way which would make it more vulnerable to XSS attacks.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2021-32764
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 11:17 UTC · Revision 1
Source evidence
Discourse is an open-source discussion platform. In Discourse versions 2.7.5 and prior, parsing and rendering of YouTube Oneboxes can be susceptible to XSS attacks. This vulnerability only affects sites which have modified or disabled Discourse's default Content Security Policy. The issue is patched in `stable` version 2.7.6, `beta` version 2.8.0.beta3, and `tests-passed` version 2.8.0.beta3. As a workaround, ensure that the Content Security Policy is enabled, and has not been modified in a way which would make it more vulnerable to XSS attacks.
osv:CVE-2021-32764
Complete source record
{
"id": "8155d03f0bd865e84dad79689e8eaa293e2a6321747d0663bdf3db5df4fac0be",
"url": "https://osv.dev/vulnerability/CVE-2021-32764",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2021-32764",
"summary": "Discourse is an open-source discussion platform. In Discourse versions 2.7.5 and prior, parsing and rendering of YouTube Oneboxes can be susceptible to XSS attacks. This vulnerability only affects sites which have modified or disabled Discourse's default Content Security Policy. The issue is patched in `stable` version 2.7.6, `beta` version 2.8.0.beta3, and `tests-passed` version 2.8.0.beta3. As a workaround, ensure that the Content Security Policy is enabled, and has not been modified in a way which would make it more vulnerable to XSS attacks.",
"evidence": "osv:CVE-2021-32764",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2021-32764",
"aliases": [
"BIT-discourse-2021-32764",
"CVE-2021-32764",
"GHSA-9x4c-29xg-56hw"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/discourse/discourse",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"last_affected": "a94a62300971415ef8cdd63b639ee24f4f6daff3"
},
{
"introduced": "05c1d3c9cdd7f3e365bedc397dd92a7e7bc2c40f"
},
{
"last_affected": "05c1d3c9cdd7f3e365bedc397dd92a7e7bc2c40f"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:discourse:discourse:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"last_affected": "2.7.5"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:discourse:discourse:2.8.0:beta1:*:*:*:*:*:*",
"range": [
{
"introduced": "2.8.0-beta1"
},
{
"last_affected": "2.8.0-beta1"
}
],
"source": "CPE_STRING"
}
]
}
}
],
"versions": [
"2.8.0-beta1",
"v2.7.5",
"v2.7.4",
"v2.7.3",
"v2.7.2",
"v2.7.1",
"v2.7.0",
"v2.8.0.beta1",
"v2.6.7",
"v2.6.6",
"v2.6.5",
"v2.6.4",
"v2.6.3",
"v2.6.2",
"v2.6.1",
"v2.6.0",
"v2.5.5",
"v2.5.4",
"v2.5.3",
"v2.5.2",
"v2.5.1",
"v2.5.0",
"v2.4.5",
"v2.4.4",
"v2.4.3",
"v2.4.2",
"v2.4.1",
"v2.4.0",
"v2.3.10",
"v2.3.9",
"v2.3.8",
"v2.3.7",
"v2.3.6",
"v2.3.5",
"v2.3.4",
"v2.3.3",
"v2.3.2",
"v2.3.1",
"v2.3.0",
"v2.2.6",
"v2.2.5",
"v2.2.4",
"v2.2.3",
"v2.2.2",
"v2.2.1",
"v2.2.0",
"v2.1.8",
"v2.1.7",
"v2.1.6",
"v2.1.5",
"v2.1.4",
"v2.1.3",
"v2.1.2",
"v2.1.1",
"v2.1.0",
"v2.0.5",
"v2.0.4",
"v2.0.3",
"v2.0.2",
"v2.0.1",
"v2.0.0",
"v1.9.7",
"v1.9.6",
"v1.9.5",
"v1.9.4",
"v1.9.3",
"v1.9.2",
"v1.9.1",
"v1.9.0",
"v1.8.11",
"v1.8.10",
"v1.8.9",
"v1.8.8",
"v1.8.7",
"v1.8.6",
"v1.8.5",
"v1.8.4",
"v1.8.3",
"v1.8.2",
"v1.8.1",
"v1.8.0",
"v1.7.10",
"v1.7.9",
"v1.7.8",
"v1.7.7",
"v1.7.6",
"v1.7.5",
"v1.7.4",
"v1.7.3",
"v1.7.2",
"v1.7.1",
"v1.7.0",
"v1.6.10",
"v1.6.9",
"v1.6.8",
"v1.6.7",
"v1.6.6",
"v1.6.5",
"v1.6.4",
"v1.6.3",
"v1.6.2",
"v1.6.1",
"v1.6.0",
"v1.5.4",
"v1.5.3",
"v1.5.2",
"v1.5.1",
"v1.5.0",
"v1.4.7",
"v1.4.6",
"v1.4.5",
"v1.4.4",
"v1.4.3",
"v1.4.2",
"v1.4.1",
"v1.4.0",
"v1.3.5",
"v1.3.4",
"v1.3.3",
"v1.3.2",
"v1.3.1",
"v1.3.0",
"v1.2.4",
"v1.2.3",
"v1.2.2",
"v1.2.1",
"v1.2.0",
"v1.1.3",
"v1.1.2",
"v1.1.1",
"v1.1.0",
"v1.0.4",
"v1.0.3",
"v1.0.2",
"v1.0.1",
"v1.0.0",
"v0.9.9.18",
"v0.9.9.17",
"v0.9.9.16",
"v0.9.9.15",
"v0.9.9.14",
"v0.9.9.13",
"v0.9.9.12",
"v0.9.9.11",
"v0.9.9.10",
"v0.9.9.9",
"v0.9.9.8",
"v0.9.9.7",
"v0.9.9.6",
"v0.9.9.5",
"v0.9.9.4",
"v0.9.9.3",
"v0.9.9.2",
"v0.9.9.1",
"v0.9.8.11",
"v0.9.8.10",
"v0.9.8.9",
"v0.9.8.8",
"v0.9.8.7",
"v0.9.8.6",
"v0.9.8.5",
"v0.9.8.4",
"v0.9.8.3",
"v0.9.8.2",
"v0.9.8.1",
"v0.9.8",
"v0.9.7.9",
"v0.9.7.8",
"v0.9.7.7",
"v0.9.7.6",
"v0.9.7.5",
"v0.9.7.4",
"v0.9.7.3",
"v0.9.7.2",
"v0.9.7.1",
"v0.9.7",
"v0.9.6.4",
"v0.9.6.3",
"v0.9.6.1",
"v0.9.6",
"v0.9.5.2",
"v0.9.5.1",
"v0.9.5",
"v0.9.4",
"v0.9.3",
"v0.9.2.6",
"v0.9.2.5",
"v0.9.2",
"v0.9.1",
"v0.9.0",
"v0.8.9",
"v0.8.8",
"v0.8.7",
"v0.8.6",
"v0.8.5",
"v0.8.4",
"v0.8.3",
"v0.8.2",
"v0.8.1",
"v0.8.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-32764.json"
}
}
],
"modified": "2026-10-20T10:53:45.672137632Z",
"provider": "osv",
"references": [
"https://github.com/discourse/discourse/security/advisories/GHSA-9x4c-29xg-56hw"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2021-32764",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 384591,
"published_at": "2021-07-15T21:15:09.373+00:00"
}