Skip to content
Heist/ feed
Back to feed
HighFix available

CVE-2017-3164: SSRF issue in Apache Solr

Type: mitigationSources: Apache Solr security

Apache Solr versions from 1.3 to 7.6.0 are affected by an SSRF issue involving the shards parameter. Upgrade to Apache Solr 7.7.0 or later and restrict network traffic to trusted sources.

Products
Apache Solr
Affected versions
Apache Solr versions from 1.3 to 7.6.0
Fixed versions
Apache Solr 7.7.0 or later
CVEs
CVE-2017-3164
Confirmed fixed CVEs
Not specified
Updated in this feed
30 Oct 2026, 22:16 UTC · Revision 1

Source evidence

CVE-2017-3164: SSRF issue in Apache Solr

official-apache-solr-security · Original source

Published 12 Feb 2019, 00:00 UTC

Apache Solr versions from 1.3 to 7.6.0 are affected by an SSRF issue involving the shards parameter. Upgrade to Apache Solr 7.7.0 or later and restrict network traffic to trusted sources.

CVE-2017-3164: SSRF issue in Apache Solr

Apache Solr

Fixed versions: Apache Solr 7.7.0 or later

Complete source record
{
  "id": "547dd58eff49f72c050cbfa985e5bcb61bb998e1bacdf16d25b5e4b30c8fa3e8",
  "url": "https://solr.apache.org/cve-2017-3164-ssrf-issue-in-apache-solr.html",
  "method": "llm",
  "payload": {
    "kind": "mitigation",
    "title": "CVE-2017-3164: SSRF issue in Apache Solr",
    "summary": "Apache Solr versions from 1.3 to 7.6.0 are affected by an SSRF issue involving the shards parameter. Upgrade to Apache Solr 7.7.0 or later and restrict network traffic to trusted sources.",
    "evidence": "CVE-2017-3164: SSRF issue in Apache Solr",
    "products": [
      {
        "name": {
          "value": "Apache Solr",
          "evidence": "Apache Solr versions from 1.3 to 7.6.0"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "Apache Solr 7.7.0 or later",
            "evidence": "Mitigation: Upgrade to Apache Solr 7.7.0 or later."
          }
        ],
        "affected_versions": [
          {
            "value": "Apache Solr versions from 1.3 to 7.6.0",
            "evidence": "Versions Affected: Apache Solr versions from 1.3 to 7.6.0"
          }
        ]
      }
    ],
    "severity": "high",
    "fixed_cves": [],
    "related_cves": [
      {
        "value": "CVE-2017-3164",
        "evidence": "CVE-2017-3164: SSRF issue in Apache Solr"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "Severity: High"
  },
  "source_id": "official-apache-solr-security",
  "document_id": 22996,
  "published_at": "2019-02-12T00:00:00+00:00"
}