Security advisory
The Site Kit by Google plugin for WordPress is vulnerable to Sensitive Information Disclosure in versions up to, and including, 1.8.0 This is due to the lack of capability checks on the admin_enqueue_scripts action which displays the connection key. This makes it possible for authenticated attackers with any level of access obtaining owner access to a site in the Google Search Console. We recommend upgrading to V1.8.1 or above.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2020-8934
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 06:03 UTC · Revision 1
Source evidence
The Site Kit by Google plugin for WordPress is vulnerable to Sensitive Information Disclosure in versions up to, and including, 1.8.0 This is due to the lack of capability checks on the admin_enqueue_scripts action which displays the connection key. This makes it possible for authenticated attackers with any level of access obtaining owner access to a site in the Google Search Console. We recommend upgrading to V1.8.1 or above.
osv:CVE-2020-8934
Complete source record
{
"id": "26c53a3f96d9d86e218284ddf51599bb2837307da3ee9b64a4d1f06a814609f3",
"url": "https://osv.dev/vulnerability/CVE-2020-8934",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2020-8934",
"summary": "The Site Kit by Google plugin for WordPress is vulnerable to Sensitive Information Disclosure in versions up to, and including, 1.8.0 This is due to the lack of capability checks on the admin_enqueue_scripts action which displays the connection key. This makes it possible for authenticated attackers with any level of access obtaining owner access to a site in the Google Search Console. We recommend upgrading to V1.8.1 or above.",
"evidence": "osv:CVE-2020-8934",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2020-8934",
"aliases": [
"CVE-2020-8934"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/google/site-kit-wp",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "d7eecdc8fcec4880dd4ffc6f00e5bc6c51158c0e"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:google:site_kit:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.8.1"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"1.8.0",
"1.7.1",
"1.7.0",
"1.5.0",
"1.4.0",
"1.3.0",
"1.2.0",
"1.1.4",
"1.1.2",
"1.1.1",
"1.1.0",
"1.0.3",
"1.0.2",
"1.0.1",
"1.0.0",
"1.0.0-rc.2",
"1.0.0-rc.1",
"1.0.0-beta.1.0.8",
"1.0.0-beta.1.0.7",
"1.0.0-beta.1.0.6",
"1.0.0-beta.1.0.5",
"1.0.0-beta.1.0.4",
"1.0.0-beta.1.0.3",
"1.0.0-beta.1.0.2",
"1.0.0-beta.1.0.1",
"1.0.0-beta.1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2020-8934.json"
}
}
],
"modified": "2026-10-24T10:30:34.731054214Z",
"provider": "osv",
"references": [
"https://www.wordfence.com/threat-intel/vulnerabilities/wordpress-plugins/google-site-kit/site-kit-by-google-171-sensitive-information-disclosure"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2020-8934",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 433597,
"published_at": "2023-07-07T12:15:09.29+00:00"
}