CriticalFix available
ap_escape_quotes buffer overflow
Type: advisorySources: OSV
ap_escape_quotes() may write beyond the end of a buffer when given malicious input. No included modules pass untrusted data to these functions, but third-party / external modules may. This issue affects Apache HTTP Server 2.4.48 and earlier.
- Products
- apache
- Affected versions
- Not specified
- Fixed versions
- 2.4.49
- CVEs
- CVE-2021-39275
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 19:49 UTC · Revision 1
Source evidence
ap_escape_quotes() may write beyond the end of a buffer when given malicious input. No included modules pass untrusted data to these functions, but third-party / external modules may. This issue affects Apache HTTP Server 2.4.48 and earlier.
osv:BIT-apache-2021-39275
apache
Fixed versions: 2.4.49
Complete source record
{
"id": "99410de1c9bc3830f1edd295a49685509e22067fbecec08f5d57bce4f273da8b",
"url": "https://osv.dev/vulnerability/BIT-apache-2021-39275",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "ap_escape_quotes buffer overflow",
"summary": "ap_escape_quotes() may write beyond the end of a buffer when given malicious input. No included modules pass untrusted data to these functions, but third-party / external modules may. This issue affects Apache HTTP Server 2.4.48 and earlier.",
"evidence": "osv:BIT-apache-2021-39275",
"products": [
{
"name": {
"value": "apache",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.4.49",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
}
],
"severity": "critical",
"structured": {
"id": "BIT-apache-2021-39275",
"aliases": [
"BIT-apache-2021-39275",
"CVE-2021-39275"
],
"affected": [
{
"ranges": [
{
"type": "SEMVER",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.4.49"
}
]
}
],
"package": {
"name": "apache",
"purl": "pkg:bitnami/apache",
"ecosystem": "Bitnami"
},
"severity": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"database_specific": {
"source": "https://github.com/bitnami/vulndb/tree/main/data/apache/BIT-apache-2021-39275.json"
}
}
],
"modified": "2026-10-16T09:45:02.792155951Z",
"provider": "osv",
"references": [
"https://httpd.apache.org/security/vulnerabilities_24.html",
"https://lists.apache.org/thread.html/r3925e167d5eb1c75def3750c155d753064e1d34a143028bb32910432%40%3Cusers.httpd.apache.org%3E",
"https://lists.apache.org/thread.html/r61fdbfc26ab170f4e6492ef3bd5197c20b862ce156e9d5a54d4b899c%40%3Cusers.httpd.apache.org%3E",
"https://lists.apache.org/thread.html/r82838efc5fa6fc4c73986399c9b71573589f78b31846aff5bd9b1697%40%3Cusers.httpd.apache.org%3E",
"https://lists.apache.org/thread.html/r82c077663f9759c7df5a6656f925b3ee4f55fcd33c889ba7cd687029%40%3Cusers.httpd.apache.org%3E",
"https://lists.debian.org/debian-lts-announce/2021/10/msg00001.html",
"https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/SPBR6WUYBJNACHKE65SPL7TJOHX7RHWD/",
"https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ZNCYSR3BXT36FFF4XTCPL3HDQK4VP45R/",
"https://security.gentoo.org/glsa/202208-20",
"https://security.netapp.com/advisory/ntap-20211008-0004/",
"https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-apache-httpd-2.4.49-VWL69sWQ",
"https://www.debian.org/security/2021/dsa-4982",
"https://www.oracle.com/security-alerts/cpuapr2022.html",
"https://www.oracle.com/security-alerts/cpujan2022.html",
"https://nvd.nist.gov/vuln/detail/CVE-2021-39275"
],
"provider_metadata": {
"cpes": [
"cpe:2.3:a:apache:http_server:*:*:*:*:*:*:*:*"
],
"severity": "Critical"
}
},
"related_cves": [
{
"value": "CVE-2021-39275",
"evidence": "/aliases"
}
],
"security_relevant": true,
"severity_evidence": "/database_specific/severity"
},
"source_id": "core-osv",
"document_id": 338123,
"published_at": "2024-03-06T10:55:11.163+00:00"
}