trafficserver — security advisory
Improper Input Validation vulnerability in Apache Software Foundation Apache Traffic Server. The configuration option proxy.config.http.push_method_enabled didn't function. However, by default the PUSH method is blocked in the ip_allow configuration file.This issue affects Apache Traffic Server: from 8.0.0 through 9.2.0. 8.x users should upgrade to 8.1.7 or later versions 9.x users should upgrade to 9.2.1 or later versions
- Products
- trafficserver
- Affected versions
- 9.2.0+ds-2
- Fixed versions
- 9.2.0+ds-2+deb12u1
- CVEs
- CVE-2023-30631
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 15:54 UTC · Revision 1
Source evidence
Improper Input Validation vulnerability in Apache Software Foundation Apache Traffic Server. The configuration option proxy.config.http.push_method_enabled didn't function. However, by default the PUSH method is blocked in the ip_allow configuration file.This issue affects Apache Traffic Server: from 8.0.0 through 9.2.0. 8.x users should upgrade to 8.1.7 or later versions 9.x users should upgrade to 9.2.1 or later versions
osv:DEBIAN-CVE-2023-30631
trafficserver
Fixed versions: 9.2.0+ds-2+deb12u1
Complete source record
{
"id": "257951b1bfc33b9a7ade010e8014eec1b25aefc76dd501ed2d7619b3cb15f8ec",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2023-30631",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2023-30631",
"summary": "Improper Input Validation vulnerability in Apache Software Foundation Apache Traffic Server. The configuration option proxy.config.http.push_method_enabled didn't function. However, by default the PUSH method is blocked in the ip_allow configuration file.This issue affects Apache Traffic Server: from 8.0.0 through 9.2.0. 8.x users should upgrade to 8.1.7 or later versions 9.x users should upgrade to 9.2.1 or later versions",
"evidence": "osv:DEBIAN-CVE-2023-30631",
"products": [
{
"name": {
"value": "trafficserver",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "9.2.0+ds-2+deb12u1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "9.2.0+ds-2",
"evidence": "/affected/0/versions"
}
]
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2023-30631",
"aliases": [
"DEBIAN-CVE-2023-30631"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "9.2.0+ds-2+deb12u1"
}
]
}
],
"package": {
"name": "trafficserver",
"purl": "pkg:deb/debian/trafficserver?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"9.2.0+ds-2"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-30631.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-26T18:02:24.791462060Z",
"provider": "osv",
"upstream": [
"CVE-2023-30631"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2023-30631"
]
},
"related_cves": [
{
"value": "CVE-2023-30631",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 456004,
"published_at": "2023-06-14T08:15:09.257+00:00"
}