Security advisory
Moderator Toolbox (reddit-moderator-toolbox) before 4.0.14 contains a stored cross-site scripting vulnerability in the removalreasons module, which inserts subreddit toolbox wiki fields into popup HTML without encoding. Attackers who can edit the toolbox wiki page can plant JavaScript in fields like pmsubject, header, or reason titles to act with moderators' Reddit sessions.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2016-20098
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 09:42 UTC · Revision 1
Source evidence
Moderator Toolbox (reddit-moderator-toolbox) before 4.0.14 contains a stored cross-site scripting vulnerability in the removalreasons module, which inserts subreddit toolbox wiki fields into popup HTML without encoding. Attackers who can edit the toolbox wiki page can plant JavaScript in fields like pmsubject, header, or reason titles to act with moderators' Reddit sessions.
osv:CVE-2016-20098
Complete source record
{
"id": "75286c1e26c654788dc763458a9aaa0177ae841d0dc12fd6fd125257054ff3e1",
"url": "https://osv.dev/vulnerability/CVE-2016-20098",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2016-20098",
"summary": "Moderator Toolbox (reddit-moderator-toolbox) before 4.0.14 contains a stored cross-site scripting vulnerability in the removalreasons module, which inserts subreddit toolbox wiki fields into popup HTML without encoding. Attackers who can edit the toolbox wiki page can plant JavaScript in fields like pmsubject, header, or reason titles to act with moderators' Reddit sessions.",
"evidence": "osv:CVE-2016-20098",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2016-20098",
"aliases": [
"CVE-2016-20098"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/toolbox-team/reddit-moderator-toolbox",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "5197fc0328eb73a3313882c4fbe713deee201dd0"
},
{
"fixed": "26f45ba21d84cecb92b1a820896ad3bf5254376e"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "4.0.14"
}
],
"source": "DESCRIPTION"
},
{
"range": [
{
"fixed": "26f45ba21d84cecb92b1a820896ad3bf5254376e"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"v3.7",
"v3.6.5",
"v3.6.4",
"v3.6.3",
"v3.6.2",
"v3.6.1",
"v3.6",
"v3.5",
"v3.4",
"v3.4RC1",
"v3.3",
"v3.3BETA2",
"v3.3BETA",
"v3.2",
"V3.1",
"v3.0.1",
"v3.0",
"3.0BETA4",
"3.0BETA3",
"3.0BETA2",
"2.3",
"v2.2",
"v2.2BETA-2",
"v2.2BETA",
"v2.1.1",
"v2.1",
"v2.1-beta1",
"v2.0",
"1.4.5",
"1.4.4",
"v1.3.1",
"v1.0",
"v0.25",
"v0.20",
"v0.13",
"v0.12"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2016-20098.json"
}
}
],
"modified": "2026-10-20T10:47:36.501260844Z",
"provider": "osv",
"references": [
"https://www.vulncheck.com/advisories/moderator-toolbox-before-4.0.14-stored-xss-via-removal-reasons-configuration",
"https://github.com/toolbox-team/reddit-moderator-toolbox/commit/26f45ba21d84cecb92b1a820896ad3bf5254376e",
"https://github.com/toolbox-team/reddit-moderator-toolbox"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2016-20098",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 379574,
"published_at": "2026-10-09T17:16:38.583+00:00"
}