HighFix available
liblouis — security advisory
A vulnerability was found in liblouis, versions 2.5.x before 2.5.4. A stack-based buffer overflow was found in findTable() in liblouis. An attacker could create a malicious file that would cause applications that use liblouis (such as Orca) to crash, or potentially execute arbitrary code when opened.
- Products
- liblouis
- Affected versions
- Not specified
- Fixed versions
- 2.6.2-1
- CVEs
- CVE-2014-8184
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 21:52 UTC · Revision 1
Source evidence
A vulnerability was found in liblouis, versions 2.5.x before 2.5.4. A stack-based buffer overflow was found in findTable() in liblouis. An attacker could create a malicious file that would cause applications that use liblouis (such as Orca) to crash, or potentially execute arbitrary code when opened.
osv:DEBIAN-CVE-2014-8184
liblouis
Fixed versions: 2.6.2-1
liblouis
Fixed versions: 2.6.2-1
liblouis
Fixed versions: 2.6.2-1
Complete source record
{
"id": "e28a482a9a584dc3fcdf41a6f901b53251960fc4345b5d3c56fbe0ed4544580e",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2014-8184",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2014-8184",
"summary": "A vulnerability was found in liblouis, versions 2.5.x before 2.5.4. A stack-based buffer overflow was found in findTable() in liblouis. An attacker could create a malicious file that would cause applications that use liblouis (such as Orca) to crash, or potentially execute arbitrary code when opened.",
"evidence": "osv:DEBIAN-CVE-2014-8184",
"products": [
{
"name": {
"value": "liblouis",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.6.2-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "liblouis",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.6.2-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "liblouis",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.6.2-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2014-8184",
"aliases": [
"DEBIAN-CVE-2014-8184"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.6.2-1"
}
]
}
],
"package": {
"name": "liblouis",
"purl": "pkg:deb/debian/liblouis?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-8184.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.6.2-1"
}
]
}
],
"package": {
"name": "liblouis",
"purl": "pkg:deb/debian/liblouis?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-8184.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.6.2-1"
}
]
}
],
"package": {
"name": "liblouis",
"purl": "pkg:deb/debian/liblouis?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-8184.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T16:01:34.003499193Z",
"provider": "osv",
"upstream": [
"CVE-2014-8184"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2014-8184"
]
},
"related_cves": [
{
"value": "CVE-2014-8184",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 414761,
"published_at": "2019-08-02T13:15:11.217+00:00"
}