Skip to content
Heist/ feed
Back to feed
High

Security advisory

Type: advisorySources: OSVCVE: CVE-2016-9587

Ansible before versions 2.1.4, 2.2.1 is vulnerable to an improper input validation in Ansible's handling of data sent from client systems. An attacker with control over a client system being managed by Ansible and the ability to send facts back to the Ansible server could use this flaw to execute arbitrary code on the Ansible server using the Ansible server privileges.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2016-9587
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 04:16 UTC · Revision 1

Source evidence

CVE-2016-9587

core-osv · Original source

Published 24 Apr 2018, 16:29 UTC

Ansible before versions 2.1.4, 2.2.1 is vulnerable to an improper input validation in Ansible's handling of data sent from client systems. An attacker with control over a client system being managed by Ansible and the ability to send facts back to the Ansible server could use this flaw to execute arbitrary code on the Ansible server using the Ansible server privileges.

osv:CVE-2016-9587
Complete source record
{
  "id": "058814a3012f4c2708df4dca9b852f2c2e952a8238337a98259c0fa8f8f70325",
  "url": "https://osv.dev/vulnerability/CVE-2016-9587",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2016-9587",
    "summary": "Ansible before versions 2.1.4, 2.2.1 is vulnerable to an improper input validation in Ansible's handling of data sent from client systems. An attacker with control over a client system being managed by Ansible and the ability to send facts back to the Ansible server could use this flaw to execute arbitrary code on the Ansible server using the Ansible server privileges.",
    "evidence": "osv:CVE-2016-9587",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2016-9587",
      "aliases": [
        "CVE-2016-9587",
        "GHSA-m956-frf4-m2wr",
        "PYSEC-2018-39"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/ansible/ansible",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2c832c736f026be4d2d5440e1bd44459b2a868aa"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:redhat:ansible:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "2.1.4"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v2.1.4.0-0.3.rc3",
            "v2.1.4.0-0.2.rc2",
            "v2.1.4.0-0.1.rc1",
            "v2.1.3.0-1",
            "v2.1.3.0-0.3.rc3",
            "v2.1.3.0-0.2.rc2",
            "v2.1.3.0-0.1.rc1",
            "v2.1.2.0-1",
            "v2.1.2.0-0.5.rc5",
            "v2.1.2.0-0.4.rc4",
            "v2.1.2.0-0.3.rc3",
            "v2.1.2.0-0.2.rc2",
            "v2.1.2.0-0.1.rc1",
            "v2.1.1.0-1",
            "v2.1.1.0-0.5.rc5",
            "v2.1.1.0-0.4.rc4",
            "v2.1.1.0-0.3.rc3",
            "v2.1.1.0-0.2.rc2",
            "v2.1.1.0-0.1.rc1",
            "v2.1.0.0-0.4.rc4",
            "v2.1.0.0-0.3.rc3",
            "v2.1.0.0-0.2.rc2",
            "v2.1.0.0-0.1.rc1",
            "v2.0.0-0.5.beta3",
            "v2.0.0-0.4.beta2",
            "v2.0.0-0.3.beta1",
            "v2.0.0-0.2.alpha2",
            "v2.0.0-0.1.alpha1",
            "v1.6.0",
            "v1.4.0",
            "v1.2",
            "v1.1",
            "v1.0",
            "0.7",
            "0.3",
            "0.0.1",
            "0.01"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2016-9587.json"
          }
        }
      ],
      "modified": "2026-10-24T10:30:16.143893466Z",
      "provider": "osv",
      "references": [
        "https://access.redhat.com/errata/RHSA-2017:0448",
        "https://access.redhat.com/errata/RHSA-2017:0515",
        "https://access.redhat.com/errata/RHSA-2017:1685",
        "https://security.gentoo.org/glsa/201701-77",
        "https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-9587",
        "https://www.exploit-db.com/exploits/41013/"
      ],
      "provider_metadata": {
        "unresolved_ranges": [
          {
            "cpes": [
              "cpe:2.3:a:ansible:ansible:*:*:*:*:*:*:*:*"
            ],
            "vendor_product": "ansible:ansible",
            "extracted_events": [
              {
                "range": [
                  {
                    "fixed": "2.2.1"
                  }
                ],
                "source": "CPE_RANGE"
              }
            ]
          },
          {
            "cpes": [
              "cpe:2.3:a:redhat:openstack:11:*:*:*:*:*:*:*"
            ],
            "vendor_product": "redhat:openstack",
            "extracted_events": [
              {
                "range": [
                  {
                    "introduced": "11"
                  },
                  {
                    "last_affected": "11"
                  }
                ],
                "source": "CPE_STRING"
              }
            ]
          }
        ]
      }
    },
    "related_cves": [
      {
        "value": "CVE-2016-9587",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 429298,
  "published_at": "2018-04-24T16:29:00.22+00:00"
}