Critical
Security advisory
Canonical snapd before version 2.37.1 incorrectly performed socket owner validation, allowing an attacker to run arbitrary commands as root. This issue affects: Canonical snapd versions prior to 2.37.1.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2019-7304
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 04:21 UTC · Revision 1
Source evidence
Canonical snapd before version 2.37.1 incorrectly performed socket owner validation, allowing an attacker to run arbitrary commands as root. This issue affects: Canonical snapd versions prior to 2.37.1.
osv:CVE-2019-7304
Complete source record
{
"id": "a2540b2e1f963e1e23a0f3530603f224f2910b3978c4b947fd9e5ce02b6a2320",
"url": "https://osv.dev/vulnerability/CVE-2019-7304",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2019-7304",
"summary": "Canonical snapd before version 2.37.1 incorrectly performed socket owner validation, allowing an attacker to run arbitrary commands as root. This issue affects: Canonical snapd versions prior to 2.37.1.",
"evidence": "osv:CVE-2019-7304",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2019-7304",
"aliases": [
"CVE-2019-7304"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/canonical/snapd",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "4a0dbb587dbf3bf8026d01930858442e9d10d68a"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:canonical:snapd:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.37.1"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"2.37",
"untagged-ec50ee5bfb45daefc236",
"2.15.2",
"2.15",
"2.14.2.16.04",
"2.14.1",
"2.14",
"2.13",
"2.12",
"2.11",
"2.0.10",
"2.0.9",
"2.0.8",
"2.0.7",
"2.0.6",
"2.0.5",
"2.0.4",
"2.0.3",
"2.0",
"1.9.4",
"1.9.3",
"1.9.2",
"1.9.1",
"1.9",
"ppa",
"1.7.3+20160310ubuntu1",
"1.7.3+20160308ubuntu1",
"1.7.3+20160303ubuntu4",
"1.7.3+20160303ubuntu3",
"1.7.3+20160303ubuntu2",
"1.7.3+20160303ubuntu1",
"1.7.3+20160225ubuntu1",
"1.7.2+20160223ubuntu1",
"1.7.2+20160204ubuntu1",
"1.7.2+20160113ubuntu1",
"1.7.2ubuntu1",
"1.7ubuntu1",
"1.6ubuntu1",
"1.5ubuntu1",
"1.4ubuntu1",
"1.3ubuntu1",
"1.2-0ubuntu1",
"1.1.2-0ubuntu1",
"1.1.1-0ubuntu1",
"1.1-0ubuntu1",
"1.0.1-0ubuntu1",
"1.0-0ubuntu1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-7304.json"
}
}
],
"modified": "2026-10-24T10:30:17.673917812Z",
"provider": "osv",
"references": [
"https://usn.ubuntu.com/3887-1/",
"https://www.exploit-db.com/exploits/46361",
"https://www.exploit-db.com/exploits/46362"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:*",
"cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:*",
"cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:*",
"cpe:2.3:o:canonical:ubuntu_linux:18.10:*:*:*:*:*:*:*"
],
"vendor_product": "canonical:ubuntu_linux",
"extracted_events": [
{
"range": [
{
"introduced": "14.04"
},
{
"last_affected": "14.04"
},
{
"introduced": "16.04"
},
{
"last_affected": "16.04"
},
{
"introduced": "18.04"
},
{
"last_affected": "18.04"
},
{
"introduced": "18.10"
},
{
"last_affected": "18.10"
}
],
"source": "CPE_STRING"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2019-7304",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 429613,
"published_at": "2019-04-23T16:29:10.797+00:00"
}