Skip to content
Heist/ feed
Back to feed
MediumFix available

rabbitmq-server — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2026-57218

RabbitMQ is a messaging and streaming broker. Prior to 4.2.6, RabbitMQ AMQP 0-9-1 allows an existing consumer to keep receiving messages after OAuth token expiry or connection.update_secret refresh to reduced scopes because existing consumers are not canceled or reauthorized at delivery time after the channel user state changes. This issue is fixed in version 4.2.6.

Products
rabbitmq-server
Affected versions
4.0.5-10, 4.0.5-11, 4.0.5-12, 4.0.5-13, 4.0.5-14, 4.0.5-6, 4.0.5-8, 4.0.5-9, 4.3.0-1
Fixed versions
4.3.0-2
CVEs
CVE-2026-57218
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 12:18 UTC · Revision 2

Source evidence

DEBIAN-CVE-2026-57218

core-osv · Original source

Published 10 Jul 2026, 21:16 UTC

RabbitMQ is a messaging and streaming broker. Prior to 4.2.6, RabbitMQ AMQP 0-9-1 allows an existing consumer to keep receiving messages after OAuth token expiry or connection.update_secret refresh to reduced scopes because existing consumers are not canceled or reauthorized at delivery time after the channel user state changes. This issue is fixed in version 4.2.6.

osv:DEBIAN-CVE-2026-57218

rabbitmq-server

Fixed versions: 4.3.0-2

Complete source record
{
  "id": "b0981fb2b0dfafe8a5634ea5268fdf16772495f235c408cef82f780452da5af4",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2026-57218",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2026-57218",
    "summary": "RabbitMQ is a messaging and streaming broker. Prior to 4.2.6, RabbitMQ AMQP 0-9-1 allows an existing consumer to keep receiving messages after OAuth token expiry or connection.update_secret refresh to reduced scopes because existing consumers are not canceled or reauthorized at delivery time after the channel user state changes. This issue is fixed in version 4.2.6.",
    "evidence": "osv:DEBIAN-CVE-2026-57218",
    "products": [
      {
        "name": {
          "value": "rabbitmq-server",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "4.3.0-2",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": [
          {
            "value": "4.0.5-10",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "4.0.5-11",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "4.0.5-12",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "4.0.5-13",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "4.0.5-14",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "4.0.5-6",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "4.0.5-8",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "4.0.5-9",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "4.3.0-1",
            "evidence": "/affected/0/versions"
          }
        ]
      }
    ],
    "severity": "medium",
    "structured": {
      "id": "DEBIAN-CVE-2026-57218",
      "aliases": [
        "DEBIAN-CVE-2026-57218"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "4.3.0-2"
                }
              ]
            }
          ],
          "package": {
            "name": "rabbitmq-server",
            "purl": "pkg:deb/debian/rabbitmq-server?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "versions": [
            "4.0.5-10",
            "4.0.5-11",
            "4.0.5-12",
            "4.0.5-13",
            "4.0.5-14",
            "4.0.5-6",
            "4.0.5-8",
            "4.0.5-9",
            "4.3.0-1"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-57218.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-26T11:47:24.317591393Z",
      "provider": "osv",
      "upstream": [
        "CVE-2026-57218"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2026-57218"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2026-57218",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 450807,
  "published_at": "2026-07-10T21:16:58.937+00:00"
}