Skip to content
Heist/ feed
Back to feed
HighFix available

libgit2 — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2018-10887

A flaw was found in libgit2 before version 0.27.3. It has been discovered that an unexpected sign extension in git_delta_apply function in delta.c file may lead to an integer overflow which in turn leads to an out of bound read, allowing to read before the base object. An attacker may use this flaw to leak memory addresses or cause a Denial of Service.

Products
libgit2
Affected versions
Not specified
Fixed versions
0.27.4+dfsg.1-0.1
CVEs
CVE-2018-10887
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 01:28 UTC · Revision 1

Source evidence

DEBIAN-CVE-2018-10887

core-osv · Original source

Published 10 Jul 2018, 14:29 UTC

A flaw was found in libgit2 before version 0.27.3. It has been discovered that an unexpected sign extension in git_delta_apply function in delta.c file may lead to an integer overflow which in turn leads to an out of bound read, allowing to read before the base object. An attacker may use this flaw to leak memory addresses or cause a Denial of Service.

osv:DEBIAN-CVE-2018-10887

libgit2

Fixed versions: 0.27.4+dfsg.1-0.1

libgit2

Fixed versions: 0.27.4+dfsg.1-0.1

libgit2

Fixed versions: 0.27.4+dfsg.1-0.1

Complete source record
{
  "id": "11cee2fb9fff61896462875254f0f6ed156d9c12029384e0b20e8fd5630cae1b",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2018-10887",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2018-10887",
    "summary": "A flaw was found in libgit2 before version 0.27.3. It has been discovered that an unexpected sign extension in git_delta_apply function in delta.c file may lead to an integer overflow which in turn leads to an out of bound read, allowing to read before the base object. An attacker may use this flaw to leak memory addresses or cause a Denial of Service.",
    "evidence": "osv:DEBIAN-CVE-2018-10887",
    "products": [
      {
        "name": {
          "value": "libgit2",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "0.27.4+dfsg.1-0.1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "libgit2",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "0.27.4+dfsg.1-0.1",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "libgit2",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "0.27.4+dfsg.1-0.1",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "high",
    "structured": {
      "id": "DEBIAN-CVE-2018-10887",
      "aliases": [
        "DEBIAN-CVE-2018-10887"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "0.27.4+dfsg.1-0.1"
                }
              ]
            }
          ],
          "package": {
            "name": "libgit2",
            "purl": "pkg:deb/debian/libgit2?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-10887.json"
          },
          "ecosystem_specific": {
            "urgency": "low"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "0.27.4+dfsg.1-0.1"
                }
              ]
            }
          ],
          "package": {
            "name": "libgit2",
            "purl": "pkg:deb/debian/libgit2?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-10887.json"
          },
          "ecosystem_specific": {
            "urgency": "low"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "0.27.4+dfsg.1-0.1"
                }
              ]
            }
          ],
          "package": {
            "name": "libgit2",
            "purl": "pkg:deb/debian/libgit2?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-10887.json"
          },
          "ecosystem_specific": {
            "urgency": "low"
          }
        }
      ],
      "modified": "2026-10-23T18:04:46.497492940Z",
      "provider": "osv",
      "upstream": [
        "CVE-2018-10887"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2018-10887"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2018-10887",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 423675,
  "published_at": "2018-07-10T14:29:00.26+00:00"
}