postgresql-15, postgresql-17 and 1 more products — security advisory
Missing authorization in PostgreSQL CREATE STATISTICS command allows a table owner to achieve denial of service against other CREATE STATISTICS users by creating in any schema. A later CREATE STATISTICS for the same name, from a user having the CREATE privilege, would then fail. Versions before PostgreSQL 18.1, 17.7, 16.11, 15.15, 14.20, and 13.23 are affected.
- Products
- postgresql-15, postgresql-17, postgresql-18
- Affected versions
- 15.10-0+deb12u1, 15.11-0+deb12u1, 15.12-0+deb12u1, 15.12-0+deb12u2, 15.13-0+deb12u1, 15.14-0+deb12u1, 15.3-0+deb12u1, 15.3-1, 15.4-0+deb12u1, 15.4-1, 15.4-2, 15.4-3, 15.5-0+deb12u1, 15.6-0+deb12u1, 15.7-0+deb12u1, 15.8-0+deb12u1, 15.9-0+deb12u1, 17.5-1, 17.6-0+deb13u1, 17.6-1, 18.0-1, 18~beta1+20250612-1, 18~beta1+20250624-1, 18~beta1+20250701-1, 18~beta1-1, 18~beta2-1, 18~beta3-1, 18~rc1-1, 18~rc1-2, 18~rc1-3, 18~~devel.20250318+g4078da6c478-1, 18~~devel.20250331-1, 18~~devel.20250405-1, 18~~devel.20250421-1, 18~~devel.20250502-1
- Fixed versions
- 15.15-0+deb12u1, 17.7-0+deb13u1, 18.1-1
- CVEs
- CVE-2025-12817
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 22:28 UTC · Revision 1
Source evidence
Missing authorization in PostgreSQL CREATE STATISTICS command allows a table owner to achieve denial of service against other CREATE STATISTICS users by creating in any schema. A later CREATE STATISTICS for the same name, from a user having the CREATE privilege, would then fail. Versions before PostgreSQL 18.1, 17.7, 16.11, 15.15, 14.20, and 13.23 are affected.
osv:DEBIAN-CVE-2025-12817
postgresql-15
Fixed versions: 15.15-0+deb12u1
postgresql-17
Fixed versions: 17.7-0+deb13u1
postgresql-18
Fixed versions: 18.1-1
Complete source record
{
"id": "faf8085bf2a80b8634dd4cf7d45762974146445e7f9ee69d897f7e6f7a224437",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2025-12817",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2025-12817",
"summary": "Missing authorization in PostgreSQL CREATE STATISTICS command allows a table owner to achieve denial of service against other CREATE STATISTICS users by creating in any schema. A later CREATE STATISTICS for the same name, from a user having the CREATE privilege, would then fail. Versions before PostgreSQL 18.1, 17.7, 16.11, 15.15, 14.20, and 13.23 are affected.",
"evidence": "osv:DEBIAN-CVE-2025-12817",
"products": [
{
"name": {
"value": "postgresql-15",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "15.15-0+deb12u1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "15.10-0+deb12u1",
"evidence": "/affected/0/versions"
},
{
"value": "15.11-0+deb12u1",
"evidence": "/affected/0/versions"
},
{
"value": "15.12-0+deb12u1",
"evidence": "/affected/0/versions"
},
{
"value": "15.12-0+deb12u2",
"evidence": "/affected/0/versions"
},
{
"value": "15.13-0+deb12u1",
"evidence": "/affected/0/versions"
},
{
"value": "15.14-0+deb12u1",
"evidence": "/affected/0/versions"
},
{
"value": "15.3-0+deb12u1",
"evidence": "/affected/0/versions"
},
{
"value": "15.3-1",
"evidence": "/affected/0/versions"
},
{
"value": "15.4-0+deb12u1",
"evidence": "/affected/0/versions"
},
{
"value": "15.4-1",
"evidence": "/affected/0/versions"
},
{
"value": "15.4-2",
"evidence": "/affected/0/versions"
},
{
"value": "15.4-3",
"evidence": "/affected/0/versions"
},
{
"value": "15.5-0+deb12u1",
"evidence": "/affected/0/versions"
},
{
"value": "15.6-0+deb12u1",
"evidence": "/affected/0/versions"
},
{
"value": "15.7-0+deb12u1",
"evidence": "/affected/0/versions"
},
{
"value": "15.8-0+deb12u1",
"evidence": "/affected/0/versions"
},
{
"value": "15.9-0+deb12u1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "postgresql-17",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "17.7-0+deb13u1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": [
{
"value": "17.5-1",
"evidence": "/affected/1/versions"
},
{
"value": "17.6-0+deb13u1",
"evidence": "/affected/1/versions"
},
{
"value": "17.6-1",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "postgresql-18",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "18.1-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": [
{
"value": "18.0-1",
"evidence": "/affected/2/versions"
},
{
"value": "18~beta1+20250612-1",
"evidence": "/affected/2/versions"
},
{
"value": "18~beta1+20250624-1",
"evidence": "/affected/2/versions"
},
{
"value": "18~beta1+20250701-1",
"evidence": "/affected/2/versions"
},
{
"value": "18~beta1-1",
"evidence": "/affected/2/versions"
},
{
"value": "18~beta2-1",
"evidence": "/affected/2/versions"
},
{
"value": "18~beta3-1",
"evidence": "/affected/2/versions"
},
{
"value": "18~rc1-1",
"evidence": "/affected/2/versions"
},
{
"value": "18~rc1-2",
"evidence": "/affected/2/versions"
},
{
"value": "18~rc1-3",
"evidence": "/affected/2/versions"
},
{
"value": "18~~devel.20250318+g4078da6c478-1",
"evidence": "/affected/2/versions"
},
{
"value": "18~~devel.20250331-1",
"evidence": "/affected/2/versions"
},
{
"value": "18~~devel.20250405-1",
"evidence": "/affected/2/versions"
},
{
"value": "18~~devel.20250421-1",
"evidence": "/affected/2/versions"
},
{
"value": "18~~devel.20250502-1",
"evidence": "/affected/2/versions"
}
]
}
],
"severity": "low",
"structured": {
"id": "DEBIAN-CVE-2025-12817",
"aliases": [
"DEBIAN-CVE-2025-12817"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:L"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "15.15-0+deb12u1"
}
]
}
],
"package": {
"name": "postgresql-15",
"purl": "pkg:deb/debian/postgresql-15?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"15.10-0+deb12u1",
"15.11-0+deb12u1",
"15.12-0+deb12u1",
"15.12-0+deb12u2",
"15.13-0+deb12u1",
"15.14-0+deb12u1",
"15.3-0+deb12u1",
"15.3-1",
"15.4-0+deb12u1",
"15.4-1",
"15.4-2",
"15.4-3",
"15.5-0+deb12u1",
"15.6-0+deb12u1",
"15.7-0+deb12u1",
"15.8-0+deb12u1",
"15.9-0+deb12u1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-12817.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "17.7-0+deb13u1"
}
]
}
],
"package": {
"name": "postgresql-17",
"purl": "pkg:deb/debian/postgresql-17?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"17.5-1",
"17.6-0+deb13u1",
"17.6-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-12817.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "18.1-1"
}
]
}
],
"package": {
"name": "postgresql-18",
"purl": "pkg:deb/debian/postgresql-18?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"18.0-1",
"18~beta1+20250612-1",
"18~beta1+20250624-1",
"18~beta1+20250701-1",
"18~beta1-1",
"18~beta2-1",
"18~beta3-1",
"18~rc1-1",
"18~rc1-2",
"18~rc1-3",
"18~~devel.20250318+g4078da6c478-1",
"18~~devel.20250331-1",
"18~~devel.20250405-1",
"18~~devel.20250421-1",
"18~~devel.20250502-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-12817.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T17:47:21.742995692Z",
"provider": "osv",
"upstream": [
"CVE-2025-12817"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2025-12817"
]
},
"related_cves": [
{
"value": "CVE-2025-12817",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 416536,
"published_at": "2025-11-13T13:15:45.167+00:00"
}