HighFix available
spip — security advisory
A PHP injection vulnerability in Spip before v3.2.8 allows attackers to execute arbitrary PHP code via the _oups parameter at /ecrire.
- Products
- spip
- Affected versions
- Not specified
- Fixed versions
- 3.2.8-1
- CVEs
- CVE-2022-28960
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 15:00 UTC · Revision 1
Source evidence
A PHP injection vulnerability in Spip before v3.2.8 allows attackers to execute arbitrary PHP code via the _oups parameter at /ecrire.
osv:DEBIAN-CVE-2022-28960
spip
Fixed versions: 3.2.8-1
spip
Fixed versions: 3.2.8-1
Complete source record
{
"id": "f7a22d45f77303347f61dd3df0dfa541b288fd35468b3a5bd04a3c366c8e70c1",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-28960",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2022-28960",
"summary": "A PHP injection vulnerability in Spip before v3.2.8 allows attackers to execute arbitrary PHP code via the _oups parameter at /ecrire.",
"evidence": "osv:DEBIAN-CVE-2022-28960",
"products": [
{
"name": {
"value": "spip",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.2.8-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "spip",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.2.8-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2022-28960",
"aliases": [
"DEBIAN-CVE-2022-28960"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.2.8-1"
}
]
}
],
"package": {
"name": "spip",
"purl": "pkg:deb/debian/spip?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-28960.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.2.8-1"
}
]
}
],
"package": {
"name": "spip",
"purl": "pkg:deb/debian/spip?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-28960.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-15T08:02:43.189900427Z",
"provider": "osv",
"upstream": [
"CVE-2022-28960"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2022-28960"
]
},
"related_cves": [
{
"value": "CVE-2022-28960",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 324043,
"published_at": "2022-05-19T21:15:08.107+00:00"
}