HighFix available
nsis — security advisory
NSIS (Nullsoft Scriptable Install System) 3.06.1 before 3.12 sometimes uses the Low IL temp directory when executing as SYSTEM, allowing local attackers to gain privileges (if they can cause my_GetTempFileName to return 0, as shown in the references).
- Products
- nsis
- Affected versions
- 3.08-3, 3.08-3+deb12u1, 3.09-1, 3.09-2, 3.09-3, 3.09-4, 3.10-1, 3.10-2, 3.11-1, 3.12-1
- Fixed versions
- 3.12-1
- CVEs
- CVE-2026-42171
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 17:48 UTC · Revision 2
Source evidence
NSIS (Nullsoft Scriptable Install System) 3.06.1 before 3.12 sometimes uses the Low IL temp directory when executing as SYSTEM, allowing local attackers to gain privileges (if they can cause my_GetTempFileName to return 0, as shown in the references).
osv:DEBIAN-CVE-2026-42171
nsis
Fixed versions: Not specified
nsis
Fixed versions: Not specified
nsis
Fixed versions: 3.12-1
Complete source record
{
"id": "a34f39dd9d80e52b48b7d7e1a830b8586a5efb9573fba4c5f3493222fe230b06",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2026-42171",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2026-42171",
"summary": "NSIS (Nullsoft Scriptable Install System) 3.06.1 before 3.12 sometimes uses the Low IL temp directory when executing as SYSTEM, allowing local attackers to gain privileges (if they can cause my_GetTempFileName to return 0, as shown in the references).",
"evidence": "osv:DEBIAN-CVE-2026-42171",
"products": [
{
"name": {
"value": "nsis",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "3.08-3",
"evidence": "/affected/0/versions"
},
{
"value": "3.08-3+deb12u1",
"evidence": "/affected/0/versions"
},
{
"value": "3.09-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.09-2",
"evidence": "/affected/0/versions"
},
{
"value": "3.09-3",
"evidence": "/affected/0/versions"
},
{
"value": "3.09-4",
"evidence": "/affected/0/versions"
},
{
"value": "3.10-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.10-2",
"evidence": "/affected/0/versions"
},
{
"value": "3.11-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.12-1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "nsis",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "3.11-1",
"evidence": "/affected/1/versions"
},
{
"value": "3.12-1",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "nsis",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.12-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": [
{
"value": "3.11-1",
"evidence": "/affected/2/versions"
}
]
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2026-42171",
"aliases": [
"DEBIAN-CVE-2026-42171"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "nsis",
"purl": "pkg:deb/debian/nsis?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"3.08-3",
"3.08-3+deb12u1",
"3.09-1",
"3.09-2",
"3.09-3",
"3.09-4",
"3.10-1",
"3.10-2",
"3.11-1",
"3.12-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-42171.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "nsis",
"purl": "pkg:deb/debian/nsis?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"3.11-1",
"3.12-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-42171.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.12-1"
}
]
}
],
"package": {
"name": "nsis",
"purl": "pkg:deb/debian/nsis?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"3.11-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-42171.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-27T09:47:41.672944495Z",
"provider": "osv",
"upstream": [
"CVE-2026-42171"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2026-42171"
]
},
"related_cves": [
{
"value": "CVE-2026-42171",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 461218,
"published_at": "2026-04-24T22:16:01.54+00:00"
}