High
WP Statistics < 13.2.9 - Authenticated SQLi
Type: advisorySources: OSV
The WP Statistics WordPress plugin before 13.2.9 does not escape a parameter, which could allow authenticated users to perform SQL Injection attacks. By default, the affected feature is available to users with the manage_options capability (admin+), however the plugin has a settings to allow low privilege users to access it as well.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-4230
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 5 Nov 2026, 10:13 UTC · Revision 1
Source evidence
WP Statistics < 13.2.9 - Authenticated SQLi
core-osv · Original sourcePublished 23 Jan 2023, 14:31 UTC
The WP Statistics WordPress plugin before 13.2.9 does not escape a parameter, which could allow authenticated users to perform SQL Injection attacks. By default, the affected feature is available to users with the manage_options capability (admin+), however the plugin has a settings to allow low privilege users to access it as well.
osv:CVE-2022-4230
Complete source record
{
"id": "201a34aa93389ab53ce9ee147a3b2dd017794d20178d37cff7cdf3efdb66ea80",
"url": "https://osv.dev/vulnerability/CVE-2022-4230",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "WP Statistics < 13.2.9 - Authenticated SQLi",
"summary": "The WP Statistics WordPress plugin before 13.2.9 does not escape a parameter, which could allow authenticated users to perform SQL Injection attacks. By default, the affected feature is available to users with the manage_options capability (admin+), however the plugin has a settings to allow low privilege users to access it as well.",
"evidence": "osv:CVE-2022-4230",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2022-4230",
"aliases": [
"CVE-2022-4230"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/wp-statistics/wp-statistics",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "76f906f0b0b4c297294935ff60672fbd1aa3dd5f"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:veronalabs:wp_statistics:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "13.2.9"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v13.2.8",
"v13.2.7",
"v13.2.6",
"v13.2.5",
"v13.2.4.1",
"v13.2.4",
"v13.2.3",
"v13.2.2.1",
"v13.2.2",
"13.0.7",
"13.0.5",
"13.0.4",
"13.0.3",
"13.0",
"12.6.13",
"12.6.12",
"12.6.11",
"12.6.10",
"12.6.9",
"12.6.8",
"12.6.7",
"12.6.6",
"12.6.5",
"12.6.4",
"12.6.3",
"12.6.2",
"12.6.1",
"12.6",
"12.5.7",
"12.5.6",
"12.5.5",
"12.5.4",
"12.5.3",
"12.5.2",
"12.5.1",
"12.5",
"12.4.3",
"12.4.1",
"12.4.0",
"12.3.6.4",
"12.3.6.2",
"12.3.6.1",
"12.3.6",
"12.3.5",
"12.3.4",
"12.3.3",
"12.3.2",
"12.3.1",
"12.3",
"12.2",
"12.1.3",
"12.1.2",
"12.1.1",
"12.1.0",
"12.0.12.1",
"12.0.12",
"12.0.11",
"12.0.10",
"12.0.9",
"12.0.8.1",
"12.0.8",
"12.0.7",
"12.0.6"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-4230.json"
}
}
],
"modified": "2026-10-28T02:30:43.737161466Z",
"provider": "osv",
"references": [
"https://wordpress.org/plugins",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/4xxx/CVE-2022-4230.json",
"https://nvd.nist.gov/vuln/detail/CVE-2022-4230",
"https://wpscan.com/vulnerability/a0e40cfd-b217-481c-8fc4-027a0a023312"
],
"provider_metadata": {
"cna_assigner": "WPScan",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"fixed": "13.2.9"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/4xxx/CVE-2022-4230.json"
}
},
"related_cves": [
{
"value": "CVE-2022-4230",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 511589,
"published_at": "2023-01-23T14:31:43.539+00:00"
}