Unrated
Security advisory
USBView 2.1 before 2.2 allows some local users (e.g., ones logged in via SSH) to execute arbitrary code as root because certain Polkit settings (e.g., allow_any=yes) for pkexec disable the authentication requirement. Code execution can, for example, use the --gtk-module option. This affects Ubuntu, Debian, and Gentoo.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-23220
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 15:35 UTC · Revision 1
Source evidence
USBView 2.1 before 2.2 allows some local users (e.g., ones logged in via SSH) to execute arbitrary code as root because certain Polkit settings (e.g., allow_any=yes) for pkexec disable the authentication requirement. Code execution can, for example, use the --gtk-module option. This affects Ubuntu, Debian, and Gentoo.
osv:CVE-2022-23220
Complete source record
{
"id": "abdeca85f035442c730384266af22f174408a3fa16ed3dd809c2e637733260fd",
"url": "https://osv.dev/vulnerability/CVE-2022-23220",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2022-23220",
"summary": "USBView 2.1 before 2.2 allows some local users (e.g., ones logged in via SSH) to execute arbitrary code as root because certain Polkit settings (e.g., allow_any=yes) for pkexec disable the authentication requirement. Code execution can, for example, use the --gtk-module option. This affects Ubuntu, Debian, and Gentoo.",
"evidence": "osv:CVE-2022-23220",
"products": [],
"severity": "unknown",
"structured": {
"id": "CVE-2022-23220",
"aliases": [
"CVE-2022-23220"
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/gregkh/usbview",
"type": "GIT",
"events": [
{
"introduced": "e4a0a804b388058b844c8d1e06c24b1254c49a71"
},
{
"fixed": "38e9dc56a437721f7a8b0ec1d2b4e611e090c87d"
},
{
"fixed": "bf374fa4e5b9a756789dfd88efa93806a395463b"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "2.1"
},
{
"fixed": "2.2"
}
],
"source": "DESCRIPTION"
},
{
"range": [
{
"fixed": "bf374fa4e5b9a756789dfd88efa93806a395463b"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"v2.1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-23220.json"
}
}
],
"modified": "2026-10-28T02:30:36.898746970Z",
"provider": "osv",
"references": [
"https://www.openwall.com/lists/oss-security/2022/01/21/1",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/23xxx/CVE-2022-23220.json",
"https://nvd.nist.gov/vuln/detail/CVE-2022-23220",
"https://security.gentoo.org/glsa/202310-15",
"https://www.debian.org/security/2022/dsa-5052",
"https://github.com/gregkh/usbview/commit/bf374fa4e5b9a756789dfd88efa93806a395463b"
],
"provider_metadata": {
"cna_assigner": "mitre",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/23xxx/CVE-2022-23220.json"
}
},
"related_cves": [
{
"value": "CVE-2022-23220",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 504180,
"published_at": "2022-01-21T00:00:00+00:00"
}