mpd — security advisory
Music Player Daemon (MPD) before version 0.24.11 contains a stack buffer overflow vulnerability in the pcm_unpack_24be function in src/pcm/Pack.cxx that allows unauthenticated attackers to corrupt stack memory by triggering an off-by-one write in the PCM decoder plugin. Attackers can issue two MPD commands referencing a malicious HTTP audio source to cause the unpack loop to write 1366 entries into a 1365-entry buffer, overwriting four bytes past the array boundary with three attacker-controlled bytes from an HTTP response body, resulting in daemon termination or potential code execution.
- Products
- mpd
- Affected versions
- 0.23.12-1, 0.23.14-1, 0.23.14-2, 0.23.15-1, 0.23.15-1~bpo12+1, 0.23.16-1, 0.23.17-1, 0.24-1, 0.24.1-1, 0.24.12-1, 0.24.16-1, 0.24.2-1, 0.24.2-1~bpo12+1, 0.24.3-1, 0.24.4-1, 0.24.6-1, 0.24.8-1
- Fixed versions
- 0.24.12-1
- CVEs
- CVE-2026-49127
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 17:50 UTC · Revision 2
Source evidence
Music Player Daemon (MPD) before version 0.24.11 contains a stack buffer overflow vulnerability in the pcm_unpack_24be function in src/pcm/Pack.cxx that allows unauthenticated attackers to corrupt stack memory by triggering an off-by-one write in the PCM decoder plugin. Attackers can issue two MPD commands referencing a malicious HTTP audio source to cause the unpack loop to write 1366 entries into a 1365-entry buffer, overwriting four bytes past the array boundary with three attacker-controlled bytes from an HTTP response body, resulting in daemon termination or potential code execution.
osv:DEBIAN-CVE-2026-49127
mpd
Fixed versions: Not specified
mpd
Fixed versions: Not specified
mpd
Fixed versions: 0.24.12-1
Complete source record
{
"id": "1071eea58077573f78ec43321e4d0b578b1370aec4d1c1142a2cbe1d40ab6206",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2026-49127",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2026-49127",
"summary": "Music Player Daemon (MPD) before version 0.24.11 contains a stack buffer overflow vulnerability in the pcm_unpack_24be function in src/pcm/Pack.cxx that allows unauthenticated attackers to corrupt stack memory by triggering an off-by-one write in the PCM decoder plugin. Attackers can issue two MPD commands referencing a malicious HTTP audio source to cause the unpack loop to write 1366 entries into a 1365-entry buffer, overwriting four bytes past the array boundary with three attacker-controlled bytes from an HTTP response body, resulting in daemon termination or potential code execution.",
"evidence": "osv:DEBIAN-CVE-2026-49127",
"products": [
{
"name": {
"value": "mpd",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "0.23.12-1",
"evidence": "/affected/0/versions"
},
{
"value": "0.23.14-1",
"evidence": "/affected/0/versions"
},
{
"value": "0.23.14-2",
"evidence": "/affected/0/versions"
},
{
"value": "0.23.15-1",
"evidence": "/affected/0/versions"
},
{
"value": "0.23.15-1~bpo12+1",
"evidence": "/affected/0/versions"
},
{
"value": "0.23.16-1",
"evidence": "/affected/0/versions"
},
{
"value": "0.23.17-1",
"evidence": "/affected/0/versions"
},
{
"value": "0.24-1",
"evidence": "/affected/0/versions"
},
{
"value": "0.24.1-1",
"evidence": "/affected/0/versions"
},
{
"value": "0.24.12-1",
"evidence": "/affected/0/versions"
},
{
"value": "0.24.16-1",
"evidence": "/affected/0/versions"
},
{
"value": "0.24.2-1",
"evidence": "/affected/0/versions"
},
{
"value": "0.24.2-1~bpo12+1",
"evidence": "/affected/0/versions"
},
{
"value": "0.24.3-1",
"evidence": "/affected/0/versions"
},
{
"value": "0.24.4-1",
"evidence": "/affected/0/versions"
},
{
"value": "0.24.6-1",
"evidence": "/affected/0/versions"
},
{
"value": "0.24.8-1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "mpd",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "0.24.12-1",
"evidence": "/affected/1/versions"
},
{
"value": "0.24.16-1",
"evidence": "/affected/1/versions"
},
{
"value": "0.24.4-1",
"evidence": "/affected/1/versions"
},
{
"value": "0.24.6-1",
"evidence": "/affected/1/versions"
},
{
"value": "0.24.8-1",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "mpd",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "0.24.12-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": [
{
"value": "0.24.4-1",
"evidence": "/affected/2/versions"
},
{
"value": "0.24.6-1",
"evidence": "/affected/2/versions"
},
{
"value": "0.24.8-1",
"evidence": "/affected/2/versions"
}
]
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2026-49127",
"aliases": [
"DEBIAN-CVE-2026-49127"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "mpd",
"purl": "pkg:deb/debian/mpd?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"0.23.12-1",
"0.23.14-1",
"0.23.14-2",
"0.23.15-1",
"0.23.15-1~bpo12+1",
"0.23.16-1",
"0.23.17-1",
"0.24-1",
"0.24.1-1",
"0.24.12-1",
"0.24.16-1",
"0.24.2-1",
"0.24.2-1~bpo12+1",
"0.24.3-1",
"0.24.4-1",
"0.24.6-1",
"0.24.8-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-49127.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "mpd",
"purl": "pkg:deb/debian/mpd?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"0.24.12-1",
"0.24.16-1",
"0.24.4-1",
"0.24.6-1",
"0.24.8-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-49127.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.24.12-1"
}
]
}
],
"package": {
"name": "mpd",
"purl": "pkg:deb/debian/mpd?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"0.24.4-1",
"0.24.6-1",
"0.24.8-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-49127.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-27T10:01:42.013680372Z",
"provider": "osv",
"upstream": [
"CVE-2026-49127"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2026-49127"
]
},
"related_cves": [
{
"value": "CVE-2026-49127",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 461356,
"published_at": "2026-05-28T20:16:26.387+00:00"
}