php8.2 — security advisory
In PHP versions 8.0.* before 8.0.29, 8.1.* before 8.1.20, 8.2.* before 8.2.7 when using SOAP HTTP Digest Authentication, random value generator was not checked for failure, and was using narrower range of values than it should have. In case of random generator failure, it could lead to a disclosure of 31 bits of uninitialized memory from the client to the server, and it also made easier to a malicious server to guess the client's nonce.
- Products
- php8.2
- Affected versions
- 8.2.5-2
- Fixed versions
- 8.2.7-1~deb12u1
- CVEs
- CVE-2023-3247
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 16:22 UTC · Revision 1
Source evidence
In PHP versions 8.0.* before 8.0.29, 8.1.* before 8.1.20, 8.2.* before 8.2.7 when using SOAP HTTP Digest Authentication, random value generator was not checked for failure, and was using narrower range of values than it should have. In case of random generator failure, it could lead to a disclosure of 31 bits of uninitialized memory from the client to the server, and it also made easier to a malicious server to guess the client's nonce.
osv:DEBIAN-CVE-2023-3247
php8.2
Fixed versions: 8.2.7-1~deb12u1
Complete source record
{
"id": "2dc56addf8c1562a95269cff9668d3cc90ea9158672d96b57d97535b1533bd95",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2023-3247",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2023-3247",
"summary": "In PHP versions 8.0.* before 8.0.29, 8.1.* before 8.1.20, 8.2.* before 8.2.7 when using SOAP HTTP Digest Authentication, random value generator was not checked for failure, and was using narrower range of values than it should have. In case of random generator failure, it could lead to a disclosure of 31 bits of uninitialized memory from the client to the server, and it also made easier to a malicious server to guess the client's nonce.",
"evidence": "osv:DEBIAN-CVE-2023-3247",
"products": [
{
"name": {
"value": "php8.2",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "8.2.7-1~deb12u1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "8.2.5-2",
"evidence": "/affected/0/versions"
}
]
}
],
"severity": "medium",
"structured": {
"id": "DEBIAN-CVE-2023-3247",
"aliases": [
"DEBIAN-CVE-2023-3247"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "8.2.7-1~deb12u1"
}
]
}
],
"package": {
"name": "php8.2",
"purl": "pkg:deb/debian/php8.2?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"8.2.5-2"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-3247.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-26T18:03:04.952029204Z",
"provider": "osv",
"upstream": [
"CVE-2023-3247"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2023-3247"
]
},
"related_cves": [
{
"value": "CVE-2023-3247",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 457542,
"published_at": "2023-07-22T05:15:37.46+00:00"
}