Skip to content
Heist/ feed
Back to feed
UnratedFix available

phpmyadmin — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2011-2642

Multiple cross-site scripting (XSS) vulnerabilities in the table Print view implementation in tbl_printview.php in phpMyAdmin before 3.3.10.3 and 3.4.x before 3.4.3.2 allow remote authenticated users to inject arbitrary web script or HTML via a crafted table name.

Products
phpmyadmin
Affected versions
Not specified
Fixed versions
4:3.4.3.2-1
CVEs
CVE-2011-2642
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 22:43 UTC · Revision 1

Source evidence

DEBIAN-CVE-2011-2642

core-osv · Original source

Published 1 Aug 2011, 19:55 UTC

Multiple cross-site scripting (XSS) vulnerabilities in the table Print view implementation in tbl_printview.php in phpMyAdmin before 3.3.10.3 and 3.4.x before 3.4.3.2 allow remote authenticated users to inject arbitrary web script or HTML via a crafted table name.

osv:DEBIAN-CVE-2011-2642

phpmyadmin

Fixed versions: 4:3.4.3.2-1

phpmyadmin

Fixed versions: 4:3.4.3.2-1

phpmyadmin

Fixed versions: 4:3.4.3.2-1

Complete source record
{
  "id": "0f6466b53c404e14763d1e4dec811032d4af6a947561b5f261b4331f91eddf21",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2011-2642",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2011-2642",
    "summary": "Multiple cross-site scripting (XSS) vulnerabilities in the table Print view implementation in tbl_printview.php in phpMyAdmin before 3.3.10.3 and 3.4.x before 3.4.3.2 allow remote authenticated users to inject arbitrary web script or HTML via a crafted table name.",
    "evidence": "osv:DEBIAN-CVE-2011-2642",
    "products": [
      {
        "name": {
          "value": "phpmyadmin",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "4:3.4.3.2-1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "phpmyadmin",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "4:3.4.3.2-1",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "phpmyadmin",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "4:3.4.3.2-1",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "unknown",
    "structured": {
      "id": "DEBIAN-CVE-2011-2642",
      "aliases": [
        "DEBIAN-CVE-2011-2642"
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "4:3.4.3.2-1"
                }
              ]
            }
          ],
          "package": {
            "name": "phpmyadmin",
            "purl": "pkg:deb/debian/phpmyadmin?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2011-2642.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "4:3.4.3.2-1"
                }
              ]
            }
          ],
          "package": {
            "name": "phpmyadmin",
            "purl": "pkg:deb/debian/phpmyadmin?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2011-2642.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "4:3.4.3.2-1"
                }
              ]
            }
          ],
          "package": {
            "name": "phpmyadmin",
            "purl": "pkg:deb/debian/phpmyadmin?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2011-2642.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-23T17:47:28.819990330Z",
      "provider": "osv",
      "upstream": [
        "CVE-2011-2642"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2011-2642"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2011-2642",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": null
  },
  "source_id": "core-osv",
  "document_id": 417149,
  "published_at": "2011-08-01T19:55:01.337+00:00"
}