Skip to content
Heist/ feed
Back to feed
HighFix available

util-linux — security advisory

Type: advisorySources: OSVAdvisory ID: ALPINE-CVE-2026-53614

util-linux is a random collection of Linux utilities. In util-linux 2.39.1 through 2.41.4 and 2.42 through 2.42.1, the SUID `mount` utility reads the attacker-controlled `LIBMOUNT_FORCE_MOUNT2` environment variable with `getenv()`, allowing a local low-privileged user to force the non-atomic legacy bind-mount path. With an `/etc/fstab` bind mount authorized by `user` or `users` and protected by `nosuid`, `noexec`, or `nodev`, an attacker can race the window between the initial bind mount and the remount that applies those security flags and execute a SUID program from the temporarily unprotected mount, potentially gaining root privileges. This issue is fixed in 2.41.5 and 2.42.2.

Products
util-linux
Affected versions
Not specified
Fixed versions
2.41.6-r0, 2.42.3-r0
CVEs
CVE-2026-53614
Confirmed fixed CVEs
Not specified
Updated in this feed
30 Oct 2026, 17:50 UTC · Revision 1

Source evidence

ALPINE-CVE-2026-53614

core-osv · Original source

Published 14 Oct 2026, 16:17 UTC

util-linux is a random collection of Linux utilities. In util-linux 2.39.1 through 2.41.4 and 2.42 through 2.42.1, the SUID `mount` utility reads the attacker-controlled `LIBMOUNT_FORCE_MOUNT2` environment variable with `getenv()`, allowing a local low-privileged user to force the non-atomic legacy bind-mount path. With an `/etc/fstab` bind mount authorized by `user` or `users` and protected by `nosuid`, `noexec`, or `nodev`, an attacker can race the window between the initial bind mount and the remount that applies those security flags and execute a SUID program from the temporarily unprotected mount, potentially gaining root privileges. This issue is fixed in 2.41.5 and 2.42.2.

osv:ALPINE-CVE-2026-53614

util-linux

Fixed versions: 2.41.6-r0

util-linux

Fixed versions: 2.41.6-r0

util-linux

Fixed versions: 2.42.3-r0

Complete source record
{
  "id": "c3e71a35f11743bc49c7df300968aa64d0858c61b60038a54d8bdbc7aea9096d",
  "url": "https://osv.dev/vulnerability/ALPINE-CVE-2026-53614",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "ALPINE-CVE-2026-53614",
    "summary": "util-linux is a random collection of Linux utilities. In util-linux 2.39.1 through 2.41.4 and 2.42 through 2.42.1, the SUID `mount` utility reads the attacker-controlled `LIBMOUNT_FORCE_MOUNT2` environment variable with `getenv()`, allowing a local low-privileged user to force the non-atomic legacy bind-mount path. With an `/etc/fstab` bind mount authorized by `user` or `users` and protected by `nosuid`, `noexec`, or `nodev`, an attacker can race the window between the initial bind mount and the remount that applies those security flags and execute a SUID program from the temporarily unprotected mount, potentially gaining root privileges. This issue is fixed in 2.41.5 and 2.42.2.",
    "evidence": "osv:ALPINE-CVE-2026-53614",
    "products": [
      {
        "name": {
          "value": "util-linux",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "2.41.6-r0",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "util-linux",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "2.41.6-r0",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "util-linux",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "2.42.3-r0",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "high",
    "structured": {
      "id": "ALPINE-CVE-2026-53614",
      "aliases": [
        "ALPINE-CVE-2026-53614"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2.41.6-r0"
                }
              ]
            }
          ],
          "package": {
            "name": "util-linux",
            "purl": "pkg:apk/alpine/util-linux?arch=source",
            "ecosystem": "Alpine:v3.22"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2026-53614.json"
          },
          "ecosystem_specific": {}
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2.41.6-r0"
                }
              ]
            }
          ],
          "package": {
            "name": "util-linux",
            "purl": "pkg:apk/alpine/util-linux?arch=source",
            "ecosystem": "Alpine:v3.23"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2026-53614.json"
          },
          "ecosystem_specific": {}
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2.42.3-r0"
                }
              ]
            }
          ],
          "package": {
            "name": "util-linux",
            "purl": "pkg:apk/alpine/util-linux?arch=source",
            "ecosystem": "Alpine:v3.24"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2026-53614.json"
          },
          "ecosystem_specific": {}
        }
      ],
      "modified": "2026-10-15T10:30:09.123064214Z",
      "provider": "osv",
      "upstream": [
        "CVE-2026-53614"
      ],
      "references": [
        "https://security.alpinelinux.org/vuln/CVE-2026-53614"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2026-53614",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 331269,
  "published_at": "2026-10-14T16:17:45.93+00:00"
}