Apache APISIX: Servlet-style normalization creates a route/upstream authorization mismatch
Use of Non-Canonical URL paths for authorization decisions vulnerability in Apache APISIX. In some configurations where a permissive route overlaps a protected one, a crafted encoded path can reach an upstream endpoint that the matched route's policies were never meant to cover. A request that should have been rejected is served instead, giving unauthenticated access to a protected upstream endpoint. This issue affects Apache APISIX: from 2.14.1 through 3.18.0. Users are recommended to upgrade to version 3.19.0, which fixes the issue.
- Products
- apisix
- Affected versions
- Not specified
- Fixed versions
- 3.19.0
- CVEs
- CVE-2026-94269
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 28 Oct 2026, 12:32 UTC · Revision 1
Source evidence
Apache APISIX: Servlet-style normalization creates a route/upstream authorization mismatch
core-osv · Original sourcePublished 9 Oct 2026, 10:43 UTC
Use of Non-Canonical URL paths for authorization decisions vulnerability in Apache APISIX. In some configurations where a permissive route overlaps a protected one, a crafted encoded path can reach an upstream endpoint that the matched route's policies were never meant to cover. A request that should have been rejected is served instead, giving unauthenticated access to a protected upstream endpoint. This issue affects Apache APISIX: from 2.14.1 through 3.18.0. Users are recommended to upgrade to version 3.19.0, which fixes the issue.
osv:BIT-apisix-2026-94269
apisix
Fixed versions: 3.19.0
Complete source record
{
"id": "7556d1313d91d1a4bb753b5f4ecb8acbcb3236ed3492fe88f71d9b8c8ebf91d4",
"url": "https://osv.dev/vulnerability/BIT-apisix-2026-94269",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache APISIX: Servlet-style normalization creates a route/upstream authorization mismatch",
"summary": "Use of Non-Canonical URL paths for authorization decisions vulnerability in Apache APISIX. In some configurations where a permissive route overlaps a protected one, a crafted encoded path can reach an upstream endpoint that the matched route's policies were never meant to cover. A request that should have been rejected is served instead, giving unauthenticated access to a protected upstream endpoint. This issue affects Apache APISIX: from 2.14.1 through 3.18.0. Users are recommended to upgrade to version 3.19.0, which fixes the issue.",
"evidence": "osv:BIT-apisix-2026-94269",
"products": [
{
"name": {
"value": "apisix",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.19.0",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
}
],
"severity": "medium",
"structured": {
"id": "BIT-apisix-2026-94269",
"aliases": [
"BIT-apisix-2026-94269",
"CVE-2026-94269"
],
"affected": [
{
"ranges": [
{
"type": "SEMVER",
"events": [
{
"introduced": "2.14.1"
},
{
"fixed": "3.19.0"
}
]
}
],
"package": {
"name": "apisix",
"purl": "pkg:bitnami/apisix",
"ecosystem": "Bitnami"
},
"severity": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X"
}
],
"database_specific": {
"source": "https://github.com/bitnami/vulndb/tree/main/data/apisix/BIT-apisix-2026-94269.json"
}
}
],
"modified": "2026-10-09T12:00:08.195506912Z",
"provider": "osv",
"references": [
"https://lists.apache.org/thread.html/6p7glm8jtkjrn12t7z2ybn6bplm22tns",
"https://nvd.nist.gov/vuln/detail/CVE-2026-94269"
],
"provider_metadata": {
"cpes": [
"cpe:2.3:a:apache:apisix:*:*:*:*:*:*:*:*"
],
"severity": "Medium"
}
},
"related_cves": [
{
"value": "CVE-2026-94269",
"evidence": "/aliases"
}
],
"security_relevant": true,
"severity_evidence": "/database_specific/severity"
},
"source_id": "core-osv",
"document_id": 120657,
"published_at": "2026-10-09T10:43:50.753+00:00"
}