Medium
Security advisory
Nextcloud Server before 11.0.3 is vulnerable to an inadequate escaping leading to a XSS vulnerability in the search module. To be exploitable a user has to write or paste malicious content into the search dialogue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2017-0890
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 06:26 UTC · Revision 1
Source evidence
Nextcloud Server before 11.0.3 is vulnerable to an inadequate escaping leading to a XSS vulnerability in the search module. To be exploitable a user has to write or paste malicious content into the search dialogue.
osv:CVE-2017-0890
Complete source record
{
"id": "d5e37f3c089326aeb37524064a324680780d7d0e52452cb2889f51d85c2cfaa5",
"url": "https://osv.dev/vulnerability/CVE-2017-0890",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2017-0890",
"summary": "Nextcloud Server before 11.0.3 is vulnerable to an inadequate escaping leading to a XSS vulnerability in the search module. To be exploitable a user has to write or paste malicious content into the search dialogue.",
"evidence": "osv:CVE-2017-0890",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2017-0890",
"aliases": [
"CVE-2017-0890"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/nextcloud/server",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "9649661f8fc0220b837975fe8afef5b5f7a964ec"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "11.0.3"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v11.0.3RC2",
"v11.0.3RC1",
"v11.0.2",
"v11.0.2RC1",
"v11.0.1",
"v11.0.1RC1",
"v11.0.0",
"v11.0RC2",
"v9.1.0beta1",
"v9.0.0beta2",
"v9.0beta1",
"v8.2RC1",
"v8.2beta1",
"v8.1RC2",
"v8.1.0beta2",
"v8.1.0beta1",
"v8.1.0alpha2",
"v8.1.0alpha1",
"v8.0.0",
"v8.0.0RC2",
"v8.0.0RC1",
"v8.0.0beta2",
"v8.0.0beta1",
"v8.0.0alpha2",
"v8.0.0alpha1",
"v7.0.0beta1",
"v7.0.0alpha2",
"v6.0.0RC2",
"v6.0.0RC1",
"v6.0.0beta5",
"v6.0.0beta4",
"v6.0.0beta3",
"v6.0.0beta2",
"v6.0.0alpha2",
"v5.0.0",
"v5.0.0RC3",
"v5.0.0RC2",
"v5.0.0RC1",
"v5.0.0beta2",
"v5.0.0beta1",
"v5.0.0alpha1",
"v4.5.0",
"v4.5.0RC3",
"v4.5.0RC2",
"v4.5.0RC1",
"v4.5.0beta4",
"v4.5.0beta3",
"v4.0.6",
"v4.0.5",
"v4.0.4",
"v4.0.1",
"v4.0.0",
"v4.0.0RC2",
"v4.0.0RC",
"v4.0.0beta",
"v3.0",
"v1.0.0beta1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2017-0890.json"
}
}
],
"modified": "2026-10-24T10:30:39.638329190Z",
"provider": "osv",
"references": [
"https://hackerone.com/reports/213227",
"https://nextcloud.com/security/advisory/?id=nc-sa-2017-007"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2017-0890",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 434715,
"published_at": "2017-05-08T20:29:00.163+00:00"
}