Skip to content
Heist/ feed
Back to feed
High

Gogs vulnerable to arbitrary file deletion via path traversal in wiki page update

Type: advisorySources: OSV

Gogs is an open source self-hosted Git service. In version 0.13.3 and prior, a path traversal vulnerability exists in the updateWikiPage function of Gogs. The vulnerability allows an authenticated user with write access to a repository's wiki to delete arbitrary files on the server by manipulating the old_title parameter in the wiki editing form. This issue has been patched in versions 0.13.4 and 0.14.0+dev.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2026-24135
Confirmed fixed CVEs
Not specified
Updated in this feed
3 Nov 2026, 07:10 UTC · Revision 1

Source evidence

Gogs vulnerable to arbitrary file deletion via path traversal in wiki page update

core-osv · Original source

Published 6 Feb 2026, 17:47 UTC

Gogs is an open source self-hosted Git service. In version 0.13.3 and prior, a path traversal vulnerability exists in the updateWikiPage function of Gogs. The vulnerability allows an authenticated user with write access to a repository's wiki to delete arbitrary files on the server by manipulating the old_title parameter in the wiki editing form. This issue has been patched in versions 0.13.4 and 0.14.0+dev.

osv:CVE-2026-24135
Complete source record
{
  "id": "4981efaa7d8f8e4d0aa5fe1b88e8b83ac79afb91d73b582701c25687ed43ab06",
  "url": "https://osv.dev/vulnerability/CVE-2026-24135",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Gogs vulnerable to arbitrary file deletion via path traversal in wiki page update",
    "summary": "Gogs is an open source self-hosted Git service. In version 0.13.3 and prior, a path traversal vulnerability exists in the updateWikiPage function of Gogs. The vulnerability allows an authenticated user with write access to a repository's wiki to delete arbitrary files on the server by manipulating the old_title parameter in the wiki editing form. This issue has been patched in versions 0.13.4 and 0.14.0+dev.",
    "evidence": "osv:CVE-2026-24135",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2026-24135",
      "aliases": [
        "CVE-2026-24135",
        "GHSA-jp7c-wj6q-3qf2",
        "GO-2026-4452"
      ],
      "metrics": [
        {
          "type": "CVSS_V4",
          "score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/gogs/gogs",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "d958a47a0e9d8747e399c687fdb3ec64a3b1a736"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:gogs:gogs:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "0.13.4"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "< 0.14.0+dev",
            "v0.13.4-rc.1",
            "v0.13.3-rc.1",
            "v0.13.3",
            "v0.13.2-rc.1",
            "v0.13.2",
            "v0.13.1-rc.1",
            "v0.13.1",
            "v0.13.0-rc.1",
            "v0.13.0",
            "v0.11.91",
            "v0.11.86",
            "v0.11.79",
            "v0.11.66",
            "v0.11.53",
            "v0.11.43",
            "v0.11.34",
            "v0.11.33",
            "v0.11.29",
            "v0.11.19",
            "v0.11.4",
            "v0.11",
            "v0.11rc",
            "v0.10.18",
            "v0.10.8",
            "v0.10",
            "v0.10rc",
            "v0.9.141",
            "v0.9.128",
            "v0.9.113",
            "v0.9.97",
            "v0.9.71",
            "v0.9.60",
            "v0.9.48",
            "v0.9.46",
            "v0.9.13",
            "v0.9.0",
            "v0.8.43",
            "v0.8.25",
            "v0.8.10",
            "v0.8.0",
            "v0.7.33",
            "v0.7.22",
            "v0.7.19",
            "v0.7.6",
            "v0.7.0",
            "v0.6.15",
            "v0.6.9",
            "v0.6.3",
            "v0.6.1",
            "v0.5.13",
            "v0.5.11",
            "v0.5.9",
            "v0.5.8",
            "v0.5.5",
            "v0.5.2",
            "v0.5.0",
            "v0.4.2",
            "v0.4.1",
            "v0.4.0",
            "v0.3.1",
            "v0.3.0",
            "v0.2.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-24135.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:26.797222417Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/24xxx/CVE-2026-24135.json",
        "https://github.com/gogs/gogs/security/advisories/GHSA-jp7c-wj6q-3qf2",
        "https://nvd.nist.gov/vuln/detail/CVE-2026-24135"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-22"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/24xxx/CVE-2026-24135.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2026-24135",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 493264,
  "published_at": "2026-02-06T17:47:49.935+00:00"
}