Action Controller has possible ReDoS vulnerability in HTTP Token authentication
Action Pack is a framework for handling and responding to web requests. Starting in version 4.0.0 and prior to versions 6.1.7.9, 7.0.8.5, 7.1.4.1, and 7.2.1.1, there is a possible ReDoS vulnerability in Action Controller's HTTP Token authentication. For applications using HTTP Token authentication via `authenticate_or_request_with_http_token` or similar, a carefully crafted header may cause header parsing to take an unexpected amount of time, possibly resulting in a DoS vulnerability. All users running an affected release should either upgrade to versions 6.1.7.9, 7.0.8.5, 7.1.4.1, or 7.2.1.1 or apply the relevant patch immediately. One may choose to use Ruby 3.2 as a workaround.Ruby 3.2 has mitigations for this problem, so Rails applications using Ruby 3.2 or newer are unaffected. Rails 8.0.0.beta1 depends on Ruby 3.2 or greater so is unaffected.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-47887
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 2 Nov 2026, 18:09 UTC · Revision 1
Source evidence
Action Controller has possible ReDoS vulnerability in HTTP Token authentication
core-osv · Original sourcePublished 16 Oct 2024, 20:02 UTC
Action Pack is a framework for handling and responding to web requests. Starting in version 4.0.0 and prior to versions 6.1.7.9, 7.0.8.5, 7.1.4.1, and 7.2.1.1, there is a possible ReDoS vulnerability in Action Controller's HTTP Token authentication. For applications using HTTP Token authentication via `authenticate_or_request_with_http_token` or similar, a carefully crafted header may cause header parsing to take an unexpected amount of time, possibly resulting in a DoS vulnerability. All users running an affected release should either upgrade to versions 6.1.7.9, 7.0.8.5, 7.1.4.1, or 7.2.1.1 or apply the relevant patch immediately. One may choose to use Ruby 3.2 as a workaround.Ruby 3.2 has mitigations for this problem, so Rails applications using Ruby 3.2 or newer are unaffected. Rails 8.0.0.beta1 depends on Ruby 3.2 or greater so is unaffected.
osv:CVE-2024-47887
Complete source record
{
"id": "2eb0f6d67d6de6d6b63ccb926907d0e49668945adcb66ef62d75dc741abb16d4",
"url": "https://osv.dev/vulnerability/CVE-2024-47887",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Action Controller has possible ReDoS vulnerability in HTTP Token authentication",
"summary": "Action Pack is a framework for handling and responding to web requests. Starting in version 4.0.0 and prior to versions 6.1.7.9, 7.0.8.5, 7.1.4.1, and 7.2.1.1, there is a possible ReDoS vulnerability in Action Controller's HTTP Token authentication. For applications using HTTP Token authentication via `authenticate_or_request_with_http_token` or similar, a carefully crafted header may cause header parsing to take an unexpected amount of time, possibly resulting in a DoS vulnerability. All users running an affected release should either upgrade to versions 6.1.7.9, 7.0.8.5, 7.1.4.1, or 7.2.1.1 or apply the relevant patch immediately. One may choose to use Ruby 3.2 as a workaround.Ruby 3.2 has mitigations for this problem, so Rails applications using Ruby 3.2 or newer are unaffected. Rails 8.0.0.beta1 depends on Ruby 3.2 or greater so is unaffected.",
"evidence": "osv:CVE-2024-47887",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2024-47887",
"aliases": [
"BIT-rails-2024-47887",
"CVE-2024-47887",
"GHSA-vfg9-r3fq-jvx4"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/rails/rails",
"type": "GIT",
"events": [
{
"introduced": "375d9a0a7fb329b0fbbd75a13e93e53a00520587"
},
{
"fixed": "b2fbbfbcaa3d662c68a9ee21ab6cf95eccc2b4ec"
},
{
"introduced": "984c3ef2775781d47efa9f541ce570daa2434a80"
},
{
"fixed": "f61f4ef957f80e1668797fce8a2393f3edb7ed76"
},
{
"introduced": "d39db5d1891f7509cde2efc425c9d69bbb77e670"
},
{
"fixed": "5b5f0da552f62e85e31e2d747d52aed2a3133f48"
},
{
"introduced": "fb6c4305939da06efdf2893d99130e7829c53e8b"
},
{
"fixed": "a1f6a13f691e0929d40b7e1b1e0d31aa69778128"
},
{
"fixed": "56b2fc3302836405b496e196a8d5fc0195e55049"
},
{
"fixed": "7c1398854d51f9bb193fb79f226647351133d08a"
},
{
"fixed": "8e057db25bff1dc7a98e9ae72e0083825b9ac545"
},
{
"fixed": "f4dc83d8926509d0958ec21fcdbc2e7df3d32ce2"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "4.0.0"
},
{
"fixed": "6.1.7.9"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"range": [
{
"introduced": "7.0.0"
},
{
"fixed": "7.0.8.5"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"range": [
{
"introduced": "7.1.0"
},
{
"fixed": "7.1.4.1"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"range": [
{
"introduced": "7.2.0"
},
{
"fixed": "7.2.1.1"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"range": [
{
"fixed": "56b2fc3302836405b496e196a8d5fc0195e55049"
}
],
"source": "REFERENCES_COMMIT"
},
{
"range": [
{
"fixed": "7c1398854d51f9bb193fb79f226647351133d08a"
}
],
"source": "REFERENCES_COMMIT"
},
{
"range": [
{
"fixed": "8e057db25bff1dc7a98e9ae72e0083825b9ac545"
}
],
"source": "REFERENCES_COMMIT"
},
{
"range": [
{
"fixed": "f4dc83d8926509d0958ec21fcdbc2e7df3d32ce2"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"v7.0.8.4",
"v7.1.4",
"v7.0.8.3",
"v7.0.8.2",
"v7.0.8.1",
"v7.0.8",
"v7.1.3",
"v7.1.2",
"v7.1.1",
"v7.1.0",
"v7.0.7",
"v7.0.6",
"v7.0.5",
"v7.0.4",
"v7.0.3",
"v7.0.2",
"v7.0.1",
"v7.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-47887.json"
}
}
],
"modified": "2026-10-28T02:30:22.152999938Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/47xxx/CVE-2024-47887.json",
"https://github.com/rails/rails/security/advisories/GHSA-vfg9-r3fq-jvx4",
"https://nvd.nist.gov/vuln/detail/CVE-2024-47887",
"https://github.com/rails/rails/commit/56b2fc3302836405b496e196a8d5fc0195e55049",
"https://github.com/rails/rails/commit/7c1398854d51f9bb193fb79f226647351133d08a",
"https://github.com/rails/rails/commit/8e057db25bff1dc7a98e9ae72e0083825b9ac545",
"https://github.com/rails/rails/commit/f4dc83d8926509d0958ec21fcdbc2e7df3d32ce2"
],
"provider_metadata": {
"cwe_ids": [
"CWE-1333"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/47xxx/CVE-2024-47887.json"
}
},
"related_cves": [
{
"value": "CVE-2024-47887",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 488136,
"published_at": "2024-10-16T20:02:34.722+00:00"
}