Skip to content
Heist/ feed
Back to feed
UnratedFix available

apache2 — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2014-8109

mod_lua.c in the mod_lua module in the Apache HTTP Server 2.3.x and 2.4.x through 2.4.10 does not support an httpd configuration in which the same Lua authorization provider is used with different arguments within different contexts, which allows remote attackers to bypass intended access restrictions in opportunistic circumstances by leveraging multiple Require directives, as demonstrated by a configuration that specifies authorization for one group to access a certain directory, and authorization for a second group to access a second directory.

Products
apache2
Affected versions
Not specified
Fixed versions
2.4.10-9
CVEs
CVE-2014-8109
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 21:45 UTC · Revision 1

Source evidence

DEBIAN-CVE-2014-8109

core-osv · Original source

Published 29 Dec 2014, 23:59 UTC

mod_lua.c in the mod_lua module in the Apache HTTP Server 2.3.x and 2.4.x through 2.4.10 does not support an httpd configuration in which the same Lua authorization provider is used with different arguments within different contexts, which allows remote attackers to bypass intended access restrictions in opportunistic circumstances by leveraging multiple Require directives, as demonstrated by a configuration that specifies authorization for one group to access a certain directory, and authorization for a second group to access a second directory.

osv:DEBIAN-CVE-2014-8109

apache2

Fixed versions: 2.4.10-9

apache2

Fixed versions: 2.4.10-9

apache2

Fixed versions: 2.4.10-9

Complete source record
{
  "id": "9c6d9c5af4d51906a48f62383122ccd156a957b6589b1f910674ce5c9dd42986",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2014-8109",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2014-8109",
    "summary": "mod_lua.c in the mod_lua module in the Apache HTTP Server 2.3.x and 2.4.x through 2.4.10 does not support an httpd configuration in which the same Lua authorization provider is used with different arguments within different contexts, which allows remote attackers to bypass intended access restrictions in opportunistic circumstances by leveraging multiple Require directives, as demonstrated by a configuration that specifies authorization for one group to access a certain directory, and authorization for a second group to access a second directory.",
    "evidence": "osv:DEBIAN-CVE-2014-8109",
    "products": [
      {
        "name": {
          "value": "apache2",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "2.4.10-9",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "apache2",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "2.4.10-9",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "apache2",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "2.4.10-9",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "unknown",
    "structured": {
      "id": "DEBIAN-CVE-2014-8109",
      "aliases": [
        "DEBIAN-CVE-2014-8109"
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2.4.10-9"
                }
              ]
            }
          ],
          "package": {
            "name": "apache2",
            "purl": "pkg:deb/debian/apache2?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-8109.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2.4.10-9"
                }
              ]
            }
          ],
          "package": {
            "name": "apache2",
            "purl": "pkg:deb/debian/apache2?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-8109.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2.4.10-9"
                }
              ]
            }
          ],
          "package": {
            "name": "apache2",
            "purl": "pkg:deb/debian/apache2?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-8109.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-23T15:47:35.592222336Z",
      "provider": "osv",
      "upstream": [
        "CVE-2014-8109"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2014-8109"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2014-8109",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": null
  },
  "source_id": "core-osv",
  "document_id": 414319,
  "published_at": "2014-12-29T23:59:00.053+00:00"
}