Skip to content
Heist/ feed
Back to feed
Medium

Security advisory

Type: advisorySources: OSVCVE: CVE-2016-15022

A vulnerability was found in mosbth cimage up to 0.7.18. It has been declared as problematic. Affected by this vulnerability is an unknown functionality of the file check_system.php. The manipulation of the argument $_SERVER['SERVER_SOFTWARE'] leads to cross site scripting. The attack can be launched remotely. The complexity of an attack is rather high. The exploitation appears to be difficult. Upgrading to version 0.7.19 is able to address this issue. The patch is named 401478c8393989836beeddfeac5ce44570af162b. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-219715.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2016-15022
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 09:37 UTC · Revision 1

Source evidence

CVE-2016-15022

core-osv · Original source

Published 29 Jan 2023, 19:15 UTC

A vulnerability was found in mosbth cimage up to 0.7.18. It has been declared as problematic. Affected by this vulnerability is an unknown functionality of the file check_system.php. The manipulation of the argument $_SERVER['SERVER_SOFTWARE'] leads to cross site scripting. The attack can be launched remotely. The complexity of an attack is rather high. The exploitation appears to be difficult. Upgrading to version 0.7.19 is able to address this issue. The patch is named 401478c8393989836beeddfeac5ce44570af162b. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-219715.

osv:CVE-2016-15022
Complete source record
{
  "id": "fb4490df38e136b708215ca317f3c863e1b80ddf3a9dfda9e94ef1241a2e7983",
  "url": "https://osv.dev/vulnerability/CVE-2016-15022",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2016-15022",
    "summary": "A vulnerability was found in mosbth cimage up to 0.7.18. It has been declared as problematic. Affected by this vulnerability is an unknown functionality of the file check_system.php. The manipulation of the argument $_SERVER['SERVER_SOFTWARE'] leads to cross site scripting. The attack can be launched remotely. The complexity of an attack is rather high. The exploitation appears to be difficult. Upgrading to version 0.7.19 is able to address this issue. The patch is named 401478c8393989836beeddfeac5ce44570af162b. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-219715.",
    "evidence": "osv:CVE-2016-15022",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2016-15022",
      "aliases": [
        "CVE-2016-15022",
        "GHSA-6hv3-9fqx-8pg5"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/mosbth/cimage",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "f9604518e478a5097f29f991b61ba8ee36e7e5ba"
                },
                {
                  "fixed": "401478c8393989836beeddfeac5ce44570af162b"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:cimage:cimage:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "0.7.19"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "401478c8393989836beeddfeac5ce44570af162b"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  },
                  {
                    "range": [
                      {
                        "fixed": "f9604518e478a5097f29f991b61ba8ee36e7e5ba"
                      }
                    ],
                    "source": "REFERENCES_TAG",
                    "original_tag": "v0.7.19"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v0.7.18",
            "v0.7.17",
            "v0.7.16",
            "v0.7.15",
            "v0.7.14",
            "v0.7.13",
            "v0.7.12",
            "v0.7.11",
            "v0.7.10",
            "v0.7.9",
            "v0.7.8",
            "v0.7.7",
            "v0.7.6",
            "v0.7.5",
            "v0.7.4",
            "v0.7.3",
            "v0.7.1",
            "v0.7.0",
            "v0.7.0-rc.2",
            "v0.7.0-rc.1",
            "v0.6.2",
            "v0.6",
            "v0.5.3",
            "v0.5.2",
            "v0.5.1",
            "v0.5",
            "v0.4.1",
            "v0.4",
            "v0.3",
            "v0.2",
            "v0.1.1",
            "v0.1"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2016-15022.json"
          }
        }
      ],
      "modified": "2026-10-20T10:46:02.783422561Z",
      "provider": "osv",
      "references": [
        "https://github.com/mosbth/cimage/releases/tag/v0.7.19",
        "https://vuldb.com/?ctiid.219715",
        "https://vuldb.com/?id.219715",
        "https://github.com/mosbth/cimage/commit/401478c8393989836beeddfeac5ce44570af162b"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2016-15022",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 379312,
  "published_at": "2023-01-29T19:15:08.94+00:00"
}