Apache ActiveMQ, Apache ActiveMQ Web: ActiveMQ Web Console - XSS vulnerability when browsing queues
Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in Apache ActiveMQ, Apache ActiveMQ Web. An authenticated attacker can show malicious content when browsing queues in the web console by overriding the content type to be HTML (instead of XML) and by injecting HTML into a JMS selector field. This issue affects Apache ActiveMQ: before 5.19.6, from 6.0.0 before 6.2.5; Apache ActiveMQ Web: before 5.19.6, from 6.0.0 before 6.2.5. Users are recommended to upgrade to version 6.2.5 or 5.19.6, which fixes the issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-41043
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 20:47 UTC · Revision 1
Source evidence
Apache ActiveMQ, Apache ActiveMQ Web: ActiveMQ Web Console - XSS vulnerability when browsing queues
core-osv · Original sourcePublished 24 Apr 2026, 10:16 UTC
Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in Apache ActiveMQ, Apache ActiveMQ Web. An authenticated attacker can show malicious content when browsing queues in the web console by overriding the content type to be HTML (instead of XML) and by injecting HTML into a JMS selector field. This issue affects Apache ActiveMQ: before 5.19.6, from 6.0.0 before 6.2.5; Apache ActiveMQ Web: before 5.19.6, from 6.0.0 before 6.2.5. Users are recommended to upgrade to version 6.2.5 or 5.19.6, which fixes the issue.
osv:CVE-2026-41043
Complete source record
{
"id": "e5200e8b01a5f444aff0dbbc4f1c3bf0198451fcb51396e5c374ad5210427d1b",
"url": "https://osv.dev/vulnerability/CVE-2026-41043",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache ActiveMQ, Apache ActiveMQ Web: ActiveMQ Web Console - XSS vulnerability when browsing queues",
"summary": "Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in Apache ActiveMQ, Apache ActiveMQ Web. An authenticated attacker can show malicious content when browsing queues in the web console by overriding the content type to be HTML (instead of XML) and by injecting HTML into a JMS selector field. This issue affects Apache ActiveMQ: before 5.19.6, from 6.0.0 before 6.2.5; Apache ActiveMQ Web: before 5.19.6, from 6.0.0 before 6.2.5. Users are recommended to upgrade to version 6.2.5 or 5.19.6, which fixes the issue.",
"evidence": "osv:CVE-2026-41043",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2026-41043",
"aliases": [
"BIT-activemq-2026-41043",
"CVE-2026-41043",
"GHSA-2jp3-2923-9h52"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/activemq",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "cf52dd245cd2ae93d81668bbd472ac995bf25f69"
},
{
"introduced": "14bac13f40958c1a1d3d198051eed32facc4abd1"
},
{
"fixed": "cfa799820a577f819b2dfd8e49341b1084a358b9"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:apache:activemq:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "5.19.6"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:apache:activemq:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "6.0.0"
},
{
"fixed": "6.2.5"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"activemq-6.2.1",
"activemq-5.19.2",
"activemq-6.2.0",
"activemq-5.19.1",
"activemq-5.19.0",
"activemq-5.18.6",
"activemq-5.18.5",
"activemq-6.1.2",
"activemq-5.18.4",
"activemq-6.1.1",
"activemq-6.1.0",
"activemq-6.0.0",
"activemq-5.18.3",
"activemq-5.18.2",
"activemq-5.18.1",
"activemq-5.18.0",
"activemq-5.16.0",
"activemq-5.15.0",
"activemq-5.14.0",
"activemq-5.13.0",
"activemq-5.12.0",
"activemq-5.11.0",
"activemq-5.10.0",
"activemq-5.9.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-41043.json"
}
}
],
"modified": "2026-10-28T02:30:39.285544008Z",
"provider": "osv",
"references": [
"https://repo.maven.apache.org/maven2",
"https://activemq.apache.org/security-advisories.data/CVE-2026-41043-announcement.txt",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/41xxx/CVE-2026-41043.json",
"https://nvd.nist.gov/vuln/detail/CVE-2026-41043"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79",
"CWE-915"
],
"cna_assigner": "apache",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"fixed": "5.19.6"
},
{
"introduced": "6.0.0"
},
{
"fixed": "6.2.5"
},
{
"fixed": "5.19.6"
},
{
"introduced": "6.0.0"
},
{
"fixed": "6.2.5"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/41xxx/CVE-2026-41043.json"
}
},
"related_cves": [
{
"value": "CVE-2026-41043",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 506845,
"published_at": "2026-04-24T10:16:23.81+00:00"
}