High
Security advisory
Incorrect access control in the WebUI in OPNsense before version 19.1.8, and pfsense before 2.4.4-p3 allows remote authenticated users to escalate privileges to administrator via a specially crafted request.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2019-11816
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 04:49 UTC · Revision 1
Source evidence
Incorrect access control in the WebUI in OPNsense before version 19.1.8, and pfsense before 2.4.4-p3 allows remote authenticated users to escalate privileges to administrator via a specially crafted request.
osv:CVE-2019-11816
Complete source record
{
"id": "21dbc164071f3817bdb046d52f85d56bd2641b63dca88a1f8da7d19b3f24402b",
"url": "https://osv.dev/vulnerability/CVE-2019-11816",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2019-11816",
"summary": "Incorrect access control in the WebUI in OPNsense before version 19.1.8, and pfsense before 2.4.4-p3 allows remote authenticated users to escalate privileges to administrator via a specially crafted request.",
"evidence": "osv:CVE-2019-11816",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2019-11816",
"aliases": [
"CVE-2019-11816"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/opnsense/core",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "dff8692b8a230b7a561f8e1fc1cd458318621097"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:opnsense:opnsense:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "19.1.8"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"19.1.7",
"19.1.6",
"19.1.5",
"19.1.4",
"19.1.3",
"19.1.2",
"19.1.1",
"19.1",
"19.1.r2",
"19.1.r1",
"19.1.b",
"19.1.a",
"18.7.r",
"18.7.b",
"18.7.a",
"18.1.r",
"18.1.b",
"18.1.a",
"17.7.r",
"17.7.b",
"17.7.a",
"17.1.r",
"17.1.b",
"17.1.a",
"16.7.r",
"16.7.b",
"16.7.a",
"15.7",
"15.1.12",
"15.1.11.4",
"15.1.11.3",
"15.1.11.2",
"15.1.11.1",
"15.1.11",
"15.1.10.2",
"15.1.10",
"15.1.9.2",
"15.1.9.1",
"15.1.9",
"15.1.8.4",
"15.1.8.3",
"15.1.8.2",
"15.1.8.1",
"15.1.8",
"15.1.7.2",
"15.1.7.1",
"15.1.7",
"15.1.6.1",
"15.1.6",
"15.1.5",
"15.1.4",
"15.1.3",
"15.1.2",
"15.1.1",
"15.1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-11816.json"
}
}
],
"modified": "2026-10-24T10:30:22.373620967Z",
"provider": "osv",
"references": [
"https://forum.opnsense.org/index.php?topic=12787.0",
"https://www.netgate.com/blog/pfsense-2-4-4-release-p3-now-available.html"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:a:netgate:pfsense:*:*:*:*:*:*:*:*"
],
"vendor_product": "netgate:pfsense",
"extracted_events": [
{
"range": [
{
"last_affected": "2.4.4"
}
],
"source": "CPE_RANGE"
}
]
},
{
"cpes": [
"cpe:2.3:a:netgate:pfsense:2.4.4:p1:*:*:*:*:*:*",
"cpe:2.3:a:netgate:pfsense:2.4.4:p2:*:*:*:*:*:*"
],
"vendor_product": "netgate:pfsense",
"extracted_events": [
{
"range": [
{
"introduced": "2.4.4-p1"
},
{
"last_affected": "2.4.4-p1"
},
{
"introduced": "2.4.4-p2"
},
{
"last_affected": "2.4.4-p2"
}
],
"source": "CPE_STRING"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2019-11816",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 430663,
"published_at": "2019-05-20T22:29:00.33+00:00"
}