webkit2gtk — security advisory
An issue was discovered in certain Apple products. iOS before 11.3 is affected. Safari before 11.1 is affected. iCloud before 7.4 on Windows is affected. iTunes before 12.7.4 on Windows is affected. tvOS before 11.3 is affected. The issue involves the "WebKit" component. It allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted web site.
- Products
- webkit2gtk
- Affected versions
- Not specified
- Fixed versions
- 2.20.0-2
- CVEs
- CVE-2018-4101
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 00:30 UTC · Revision 1
Source evidence
An issue was discovered in certain Apple products. iOS before 11.3 is affected. Safari before 11.1 is affected. iCloud before 7.4 on Windows is affected. iTunes before 12.7.4 on Windows is affected. tvOS before 11.3 is affected. The issue involves the "WebKit" component. It allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted web site.
osv:DEBIAN-CVE-2018-4101
webkit2gtk
Fixed versions: 2.20.0-2
webkit2gtk
Fixed versions: 2.20.0-2
webkit2gtk
Fixed versions: 2.20.0-2
Complete source record
{
"id": "3d20a19f15ba62064648590a0021c75c1d13a38b44a42633f4b550cf638181a9",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2018-4101",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2018-4101",
"summary": "An issue was discovered in certain Apple products. iOS before 11.3 is affected. Safari before 11.1 is affected. iCloud before 7.4 on Windows is affected. iTunes before 12.7.4 on Windows is affected. tvOS before 11.3 is affected. The issue involves the \"WebKit\" component. It allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted web site.",
"evidence": "osv:DEBIAN-CVE-2018-4101",
"products": [
{
"name": {
"value": "webkit2gtk",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.20.0-2",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "webkit2gtk",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.20.0-2",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "webkit2gtk",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.20.0-2",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2018-4101",
"aliases": [
"DEBIAN-CVE-2018-4101"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.20.0-2"
}
]
}
],
"package": {
"name": "webkit2gtk",
"purl": "pkg:deb/debian/webkit2gtk?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-4101.json"
},
"ecosystem_specific": {
"urgency": "unimportant"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.20.0-2"
}
]
}
],
"package": {
"name": "webkit2gtk",
"purl": "pkg:deb/debian/webkit2gtk?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-4101.json"
},
"ecosystem_specific": {
"urgency": "unimportant"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.20.0-2"
}
]
}
],
"package": {
"name": "webkit2gtk",
"purl": "pkg:deb/debian/webkit2gtk?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-4101.json"
},
"ecosystem_specific": {
"urgency": "unimportant"
}
}
],
"modified": "2026-10-23T18:03:22.063015485Z",
"provider": "osv",
"upstream": [
"CVE-2018-4101"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2018-4101"
]
},
"related_cves": [
{
"value": "CVE-2018-4101",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 421287,
"published_at": "2018-04-03T06:29:04+00:00"
}