vLLM API endpoints vulnerable to Denial of Service Attacks
vLLM is an inference and serving engine for large language models (LLMs). From 0.1.0 to before 0.10.1.1, a Denial of Service (DoS) vulnerability can be triggered by sending a single HTTP GET request with an extremely large header to an HTTP endpoint. This results in server memory exhaustion, potentially leading to a crash or unresponsiveness. The attack does not require authentication, making it exploitable by any remote user. This vulnerability is fixed in 0.10.1.1.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-48956
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 7 Nov 2026, 12:06 UTC · Revision 1
Source evidence
vLLM API endpoints vulnerable to Denial of Service Attacks
core-osv · Original sourcePublished 21 Aug 2025, 14:41 UTC
vLLM is an inference and serving engine for large language models (LLMs). From 0.1.0 to before 0.10.1.1, a Denial of Service (DoS) vulnerability can be triggered by sending a single HTTP GET request with an extremely large header to an HTTP endpoint. This results in server memory exhaustion, potentially leading to a crash or unresponsiveness. The attack does not require authentication, making it exploitable by any remote user. This vulnerability is fixed in 0.10.1.1.
osv:CVE-2025-48956
Complete source record
{
"id": "6f9ef3e460e7ee8d5f0ee9be1bd477fab7e1ddf5b4d5a6cbd6dd9c1e9a24cfd7",
"url": "https://osv.dev/vulnerability/CVE-2025-48956",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "vLLM API endpoints vulnerable to Denial of Service Attacks",
"summary": "vLLM is an inference and serving engine for large language models (LLMs). From 0.1.0 to before 0.10.1.1, a Denial of Service (DoS) vulnerability can be triggered by sending a single HTTP GET request with an extremely large header to an HTTP endpoint. This results in server memory exhaustion, potentially leading to a crash or unresponsiveness. The attack does not require authentication, making it exploitable by any remote user. This vulnerability is fixed in 0.10.1.1.",
"evidence": "osv:CVE-2025-48956",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2025-48956",
"aliases": [
"CVE-2025-48956",
"GHSA-rxc4-3w6r-4v47",
"PYSEC-2026-2021"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/vllm-project/vllm",
"type": "GIT",
"events": [
{
"introduced": "67d96c29fba9b72cb4c4edbc26211c208a00ebdd"
},
{
"fixed": "1da94e673c257373280026f75ceb4effac80e892"
},
{
"fixed": "d8b736f913a59117803d6701521d2e4861701944"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:vllm:vllm:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0.1.0"
},
{
"fixed": "0.10.1.1"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "d8b736f913a59117803d6701521d2e4861701944"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"v0.10.1",
"v0.10.1rc1",
"v0.10.0rc2",
"v0.10.0",
"v0.10.0rc1",
"v0.9.2rc1",
"v0.9.1rc2",
"v0.9.1",
"v0.9.1rc1",
"v0.9.0",
"v0.8.4",
"v0.8.3rc1",
"v0.8.2",
"v0.8.1",
"v0.8.0rc2",
"v0.8.0rc1",
"v0.7.3",
"v0.7.2",
"v0.7.1",
"v0.7.0",
"v0.6.6.post1",
"v0.6.6",
"v0.6.5",
"v0.6.4.post1",
"v0.6.4",
"v0.6.3.post1",
"v0.6.3",
"v0.6.2",
"v0.6.1.post2",
"v0.6.1.post1",
"v0.6.1",
"v0.6.0",
"v0.5.5",
"v0.5.4",
"v0.5.3.post1",
"v0.5.3",
"v0.5.2",
"v0.5.1",
"v0.5.0.post1",
"v0.5.0",
"v0.4.3",
"v0.4.2",
"v0.4.1",
"v0.4.0.post1",
"v0.4.0",
"v0.3.3",
"v0.3.2",
"v0.3.1",
"v0.3.0",
"v0.2.7",
"v0.2.6",
"v0.2.5",
"v0.2.4",
"v0.2.3",
"v0.2.2",
"v0.2.1",
"v0.2.0",
"v0.1.7",
"v0.1.6",
"v0.1.5",
"v0.1.4",
"v0.1.3",
"v0.1.2",
"v0.1.1",
"v0.1.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-48956.json"
}
}
],
"modified": "2026-10-28T02:30:50.719971607Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/48xxx/CVE-2025-48956.json",
"https://github.com/vllm-project/vllm/security/advisories/GHSA-rxc4-3w6r-4v47",
"https://nvd.nist.gov/vuln/detail/CVE-2025-48956",
"https://github.com/vllm-project/vllm/commit/d8b736f913a59117803d6701521d2e4861701944",
"https://github.com/vllm-project/vllm/pull/23267"
],
"provider_metadata": {
"cwe_ids": [
"CWE-400"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/48xxx/CVE-2025-48956.json"
}
},
"related_cves": [
{
"value": "CVE-2025-48956",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 519234,
"published_at": "2025-08-21T14:41:03.889+00:00"
}