Skip to content
Heist/ feed
Back to feed
MediumFix available

jqueryui — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2010-5312

Cross-site scripting (XSS) vulnerability in jquery.ui.dialog.js in the Dialog widget in jQuery UI before 1.10.0 allows remote attackers to inject arbitrary web script or HTML via the title option.

Products
jqueryui
Affected versions
Not specified
Fixed versions
1.10.1+dfsg-1
CVEs
CVE-2010-5312
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 00:00 UTC · Revision 1

Source evidence

DEBIAN-CVE-2010-5312

core-osv · Original source

Published 24 Nov 2014, 16:59 UTC

Cross-site scripting (XSS) vulnerability in jquery.ui.dialog.js in the Dialog widget in jQuery UI before 1.10.0 allows remote attackers to inject arbitrary web script or HTML via the title option.

osv:DEBIAN-CVE-2010-5312

jqueryui

Fixed versions: 1.10.1+dfsg-1

jqueryui

Fixed versions: 1.10.1+dfsg-1

jqueryui

Fixed versions: 1.10.1+dfsg-1

Complete source record
{
  "id": "03a8fa85c1fb9bd438d849b488a1fcfea12ef7ebf6d238e325a3547edefe0f2a",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2010-5312",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2010-5312",
    "summary": "Cross-site scripting (XSS) vulnerability in jquery.ui.dialog.js in the Dialog widget in jQuery UI before 1.10.0 allows remote attackers to inject arbitrary web script or HTML via the title option.",
    "evidence": "osv:DEBIAN-CVE-2010-5312",
    "products": [
      {
        "name": {
          "value": "jqueryui",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1.10.1+dfsg-1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "jqueryui",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1.10.1+dfsg-1",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "jqueryui",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1.10.1+dfsg-1",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "medium",
    "structured": {
      "id": "DEBIAN-CVE-2010-5312",
      "aliases": [
        "DEBIAN-CVE-2010-5312"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1.10.1+dfsg-1"
                }
              ]
            }
          ],
          "package": {
            "name": "jqueryui",
            "purl": "pkg:deb/debian/jqueryui?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2010-5312.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1.10.1+dfsg-1"
                }
              ]
            }
          ],
          "package": {
            "name": "jqueryui",
            "purl": "pkg:deb/debian/jqueryui?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2010-5312.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1.10.1+dfsg-1"
                }
              ]
            }
          ],
          "package": {
            "name": "jqueryui",
            "purl": "pkg:deb/debian/jqueryui?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2010-5312.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-23T18:02:44.245261854Z",
      "provider": "osv",
      "upstream": [
        "CVE-2010-5312"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2010-5312"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2010-5312",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 419659,
  "published_at": "2014-11-24T16:59:00.087+00:00"
}