Parse Server crashes when receiving file download request with invalid byte range
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Versions prior to 4.10.17, and prior to 5.2.8 on the 5.x branch, crash when a file download request is received with an invalid byte range, resulting in a Denial of Service. This issue has been patched in versions 4.10.17, and 5.2.8. There are no known workarounds.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-39313
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 5 Nov 2026, 11:22 UTC · Revision 1
Source evidence
Parse Server crashes when receiving file download request with invalid byte range
core-osv · Original sourcePublished 24 Oct 2022, 00:00 UTC
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Versions prior to 4.10.17, and prior to 5.2.8 on the 5.x branch, crash when a file download request is received with an invalid byte range, resulting in a Denial of Service. This issue has been patched in versions 4.10.17, and 5.2.8. There are no known workarounds.
osv:CVE-2022-39313
Complete source record
{
"id": "761335f70ccb04bb44caff70566c068523693e78c0249fa81784135fa0c17009",
"url": "https://osv.dev/vulnerability/CVE-2022-39313",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Parse Server crashes when receiving file download request with invalid byte range",
"summary": "Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Versions prior to 4.10.17, and prior to 5.2.8 on the 5.x branch, crash when a file download request is received with an invalid byte range, resulting in a Denial of Service. This issue has been patched in versions 4.10.17, and 5.2.8. There are no known workarounds.",
"evidence": "osv:CVE-2022-39313",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2022-39313",
"aliases": [
"BIT-parse-2022-39313",
"CVE-2022-39313",
"GHSA-h423-w6qv-2wj3"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/parse-community/parse-server",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "041e60487ccfde96ec86d24acec4bc095955e438"
},
{
"introduced": "46c9a91627a0503f0364c4cc1cc9bba3c6a86d65"
},
{
"fixed": "8011b2fdace4c25a967c0193dd4d32c2dbd4e4bc"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "4.10.17"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:*",
"range": [
{
"introduced": "5.0.0"
},
{
"fixed": "5.2.8"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"4.10.16",
"5.2.7",
"4.10.15",
"5.2.6",
"4.10.14",
"5.2.5",
"4.10.13",
"5.2.4",
"5.2.3",
"4.10.12",
"5.2.2",
"4.10.11",
"5.2.1",
"4.10.10",
"4.10.9",
"5.2.0",
"4.10.8",
"5.1.1",
"5.1.0",
"5.0.0",
"4.10.7",
"4.10.6",
"4.10.5",
"4.10.4",
"4.10.3",
"4.10.2",
"4.10.1",
"4.10.0",
"4.5.2",
"4.5.0",
"4.4.0",
"4.3.0",
"4.2.0",
"4.1.0",
"4.0.2",
"4.0.1",
"4.0.0",
"3.10.0",
"3.9.0",
"3.8.0",
"3.7.2",
"3.7.1",
"3.7.0",
"3.6.0",
"3.5.0",
"3.4.0",
"3.4.1",
"3.3.0",
"3.2.3",
"3.2.2",
"3.2.1",
"3.2.0",
"3.1.3",
"3.1.2",
"3.1.1",
"3.1.0",
"3.0.0",
"2.8.2",
"2.8.0",
"2.7.4",
"2.7.3",
"2.7.2",
"2.7.1",
"2.7.0",
"2.6.5",
"2.6.4",
"2.6.3",
"2.6.2",
"2.6.1",
"2.6.0",
"2.5.3",
"2.5.2",
"2.5.1",
"2.5.0",
"2.4.2",
"2.4.1",
"2.4.0",
"2.3.8",
"2.3.7",
"2.3.6",
"2.3.5",
"2.3.4",
"2.3.3",
"2.3.2",
"2.3.1",
"2.2.25",
"2.2.25-beta.1",
"2.2.24",
"2.2.23",
"2.2.22",
"2.2.21",
"2.2.20",
"2.2.19",
"2.2.18",
"2.2.17",
"2.2.16",
"2.2.15",
"2.2.14",
"2.2.13",
"2.2.12",
"2.2.11",
"2.2.10",
"2.2.9",
"2.2.8",
"2.2.7",
"2.2.6",
"2.2.5",
"2.2.4",
"2.2.3",
"2.2.2",
"2.2.1",
"2.2.0",
"2.1.6",
"2.1.5",
"2.1.4",
"2.1.3",
"2.1.2",
"2.1.1",
"2.1.0",
"2.0.8",
"2.0.7",
"2.0.3",
"2.0.6",
"2.0.5",
"2.0.4",
"2.0.2",
"2.0.1",
"2.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-39313.json"
}
}
],
"modified": "2026-10-28T02:30:44.084129153Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/39xxx/CVE-2022-39313.json",
"https://github.com/parse-community/parse-server/security/advisories/GHSA-h423-w6qv-2wj3",
"https://nvd.nist.gov/vuln/detail/CVE-2022-39313"
],
"provider_metadata": {
"cwe_ids": [
"CWE-1284"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/39xxx/CVE-2022-39313.json"
}
},
"related_cves": [
{
"value": "CVE-2022-39313",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 511716,
"published_at": "2022-10-24T00:00:00+00:00"
}