Medium
Security advisory
Apache HTTP Server mod_cluster before version httpd 2.4.23 is vulnerable to an Improper Input Validation in the protocol parsing logic in the load balancer resulting in a Segmentation Fault in the serving httpd process.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2016-8612
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 05:35 UTC · Revision 1
Source evidence
Apache HTTP Server mod_cluster before version httpd 2.4.23 is vulnerable to an Improper Input Validation in the protocol parsing logic in the load balancer resulting in a Segmentation Fault in the serving httpd process.
osv:CVE-2016-8612
Complete source record
{
"id": "6b8f74a564776b19bb867d4068f589aedd282cec5e7ceba50ad9e7f7408ab4ec",
"url": "https://osv.dev/vulnerability/CVE-2016-8612",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2016-8612",
"summary": "Apache HTTP Server mod_cluster before version httpd 2.4.23 is vulnerable to an Improper Input Validation in the protocol parsing logic in the load balancer resulting in a Segmentation Fault in the serving httpd process.",
"evidence": "osv:CVE-2016-8612",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2016-8612",
"aliases": [
"CVE-2016-8612"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/httpd",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "ef07cb031c6f8f7ac483c26fc858aad68c365fd9"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:apache:http_server:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.4.23"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2016-8612.json"
}
}
],
"modified": "2026-10-24T10:30:30.699083200Z",
"provider": "osv",
"references": [
"https://access.redhat.com/errata/RHSA-2017:0193",
"https://access.redhat.com/errata/RHSA-2017:0194",
"https://security.netapp.com/advisory/ntap-20180601-0005/",
"https://bugzilla.redhat.com/show_bug.cgi?id=1387605"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:o:redhat:enterprise_linux:6.0:*:*:*:*:*:*:*",
"cpe:2.3:o:redhat:enterprise_linux:7.0:*:*:*:*:*:*:*"
],
"vendor_product": "redhat:enterprise_linux",
"extracted_events": [
{
"range": [
{
"introduced": "6.0"
},
{
"last_affected": "6.0"
},
{
"introduced": "7.0"
},
{
"last_affected": "7.0"
}
],
"source": "CPE_STRING"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2016-8612",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 432636,
"published_at": "2018-03-09T20:29:00.41+00:00"
}