Medium
WordPress Embed Privacy Plugin <= 1.8.0 is vulnerable to Cross Site Scripting (XSS)
Type: advisorySources: OSV
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Epiphyt Embed Privacy allows Stored XSS.This issue affects Embed Privacy: from n/a through 1.8.0.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2023-51694
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 15:07 UTC · Revision 1
Source evidence
WordPress Embed Privacy Plugin <= 1.8.0 is vulnerable to Cross Site Scripting (XSS)
core-osv · Original sourcePublished 1 Feb 2024, 11:04 UTC
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Epiphyt Embed Privacy allows Stored XSS.This issue affects Embed Privacy: from n/a through 1.8.0.
osv:CVE-2023-51694
Complete source record
{
"id": "0404e59b48fe8d9c0896ae9d08bd9e270e9c6af759302187610b2f68d8186d27",
"url": "https://osv.dev/vulnerability/CVE-2023-51694",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "WordPress Embed Privacy Plugin <= 1.8.0 is vulnerable to Cross Site Scripting (XSS)",
"summary": "Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Epiphyt Embed Privacy allows Stored XSS.This issue affects Embed Privacy: from n/a through 1.8.0.",
"evidence": "osv:CVE-2023-51694",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2023-51694",
"aliases": [
"CVE-2023-51694"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/epiphyt/embed-privacy",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"last_affected": "bebb3a6d2d6951afe366ff42c71e0e4195af1c48"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:epiph:embed_privacy:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"last_affected": "1.8.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v1.8.0",
"v1.7.3",
"v1.7.2",
"v1.7.1",
"v1.7.0",
"v1.6.5",
"v1.6.4",
"v1.6.3",
"v1.6.2",
"v1.6.1",
"v1.6.0",
"v1.5.1",
"v1.5.0",
"v1.4.8",
"v1.4.7",
"v1.4.6",
"v1.4.5",
"v1.4.4",
"v1.4.3",
"v1.4.2",
"v1.4.1",
"v1.4.0",
"1.3.6",
"1.3.5",
"1.3.4",
"1.3.3",
"1.3.2",
"1.3.1",
"1.3.0",
"1.2.2",
"1.2.1",
"1.2.0",
"v1.1.2",
"v1.1.1",
"v1.1.0",
"v1.0.2",
"v1.0.1",
"v1.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-51694.json"
}
}
],
"modified": "2026-10-28T02:30:36.729863294Z",
"provider": "osv",
"references": [
"https://wordpress.org/plugins",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/51xxx/CVE-2023-51694.json",
"https://nvd.nist.gov/vuln/detail/CVE-2023-51694",
"https://patchstack.com/database/vulnerability/embed-privacy/wordpress-embed-privacy-plugin-1-8-0-cross-site-scripting-xss-vulnerability?_s_id=cve"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "Patchstack",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"fixed": "1.8.1"
}
],
"source": "AFFECTED_FIELD",
"strategy": "ChangesAt"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/51xxx/CVE-2023-51694.json"
}
},
"related_cves": [
{
"value": "CVE-2023-51694",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 504000,
"published_at": "2024-02-01T11:04:42.028+00:00"
}