Critical
Security advisory
Node.js before 16.6.0, 14.17.4, and 12.22.4 is vulnerable to a use after free attack where an attacker might be able to exploit the memory corruption, to change process behavior.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2021-22930
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 06:23 UTC · Revision 1
Source evidence
Node.js before 16.6.0, 14.17.4, and 12.22.4 is vulnerable to a use after free attack where an attacker might be able to exploit the memory corruption, to change process behavior.
osv:CVE-2021-22930
Complete source record
{
"id": "26c843a945f00320fc56e95f1247f539a84c1c9d986f38ced7fe64447f3214ea",
"url": "https://osv.dev/vulnerability/CVE-2021-22930",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2021-22930",
"summary": "Node.js before 16.6.0, 14.17.4, and 12.22.4 is vulnerable to a use after free attack where an attacker might be able to exploit the memory corruption, to change process behavior.",
"evidence": "osv:CVE-2021-22930",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2021-22930",
"aliases": [
"BIT-node-2021-22930",
"BIT-node-min-2021-22930",
"CVE-2021-22930"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/nodejs/node",
"type": "GIT",
"events": [
{
"introduced": "2f45ad8060e13d5ac912335096d21526f2f9602b"
},
{
"fixed": "2fdf98954de7336b841f5835a5cabcbf085c873b"
},
{
"introduced": "73aa21658dfa6a22c06451d080152b32b1f98dbe"
},
{
"fixed": "488c27f71c56436af303dd6a99e4a4f82acd2e1b"
},
{
"introduced": "7162e686b18d22b4385fa5c04274fb04dbd810c7"
},
{
"fixed": "8d2e66cae33472f5d4017444fd4116a4db5667d2"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:nodejs:node.js:*:*:*:*:lts:*:*:*",
"range": [
{
"introduced": "12.0.0"
},
{
"fixed": "12.22.4"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:nodejs:node.js:*:*:*:*:lts:*:*:*",
"range": [
{
"introduced": "14.0.0"
},
{
"fixed": "14.17.4"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:nodejs:node.js:*:*:*:*:-:*:*:*",
"range": [
{
"introduced": "16.0.0"
},
{
"fixed": "16.6.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v16.5.0",
"v16.4.2",
"v14.17.3",
"v12.22.3",
"v14.17.2",
"v16.4.1",
"v12.22.2",
"v16.4.0",
"v14.17.1",
"v16.3.0",
"v16.2.0",
"v14.17.0",
"v16.1.0",
"v16.0.0",
"v14.16.1",
"v12.22.1",
"v12.22.0",
"v14.16.0",
"v12.21.0",
"v12.20.2",
"v14.15.5",
"v14.15.4",
"v12.20.1",
"v14.15.3",
"v14.15.2",
"v12.20.0",
"v12.19.1",
"v14.15.1",
"v14.15.0",
"v14.14.0",
"v14.13.1",
"v12.19.0",
"v14.13.0",
"v14.12.0",
"v12.18.4",
"v14.11.0",
"v14.10.1",
"v14.10.0",
"v14.9.0",
"v14.8.0",
"v14.7.0",
"v12.18.3",
"v14.6.0",
"v14.5.0",
"v12.18.2",
"v12.18.1",
"v12.18.0",
"v14.4.0",
"v12.17.0",
"v14.3.0",
"v14.2.0",
"v14.1.0",
"v12.16.3",
"v14.0.0",
"v12.16.2",
"v12.16.1",
"v12.16.0",
"v12.15.0",
"v12.14.1",
"v12.14.0",
"v12.13.1",
"v12.13.0",
"v12.12.0",
"v12.11.1",
"v12.11.0",
"v12.10.0",
"v12.9.1",
"v12.9.0",
"v12.8.1",
"v12.8.0",
"v12.7.0",
"v12.6.0",
"v12.5.0",
"v12.4.0",
"v12.3.1",
"v12.3.0",
"v12.2.0",
"v12.1.0",
"v12.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-22930.json"
}
}
],
"modified": "2026-10-24T10:30:38.595926848Z",
"provider": "osv",
"references": [
"https://lists.debian.org/debian-lts-announce/2022/10/msg00006.html",
"https://security.gentoo.org/glsa/202401-02",
"https://security.netapp.com/advisory/ntap-20211112-0002/",
"https://hackerone.com/reports/1238162",
"https://cert-portal.siemens.com/productcert/pdf/ssa-389290.pdf",
"https://nodejs.org/en/blog/vulnerability/july-2021-security-releases-2/"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:a:siemens:sinec_infrastructure_network_services:*:*:*:*:*:*:*:*"
],
"vendor_product": "siemens:sinec_infrastructure_network_services",
"extracted_events": [
{
"range": [
{
"fixed": "1.0.1.1"
}
],
"source": "CPE_RANGE"
}
]
},
{
"cpes": [
"cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*"
],
"vendor_product": "debian:debian_linux",
"extracted_events": [
{
"range": [
{
"introduced": "10.0"
},
{
"last_affected": "10.0"
}
],
"source": "CPE_STRING"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2021-22930",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 434494,
"published_at": "2021-10-07T14:15:08.053+00:00"
}