dmidecode — security advisory
Dmidecode before 3.5 allows -dump-bin to overwrite a local file. This has security relevance because, for example, execution of Dmidecode via Sudo is plausible. NOTE: Some third parties have indicated the fix in 3.5 does not adequately address the vulnerability. The argument is that the proposed patch prevents dmidecode from writing to an existing file. However, there are multiple attack vectors that would not require overwriting an existing file that would provide the same level of unauthorized privilege escalation (e.g. creating a new file in /etc/cron.hourly).
- Products
- dmidecode
- Affected versions
- 3.4-1, 3.5-1, 3.5-2, 3.5-3, 3.6-1, 3.6-2, 3.7-1
- Fixed versions
- 3.5-1
- CVEs
- CVE-2023-30630
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 15:54 UTC · Revision 1
Source evidence
Dmidecode before 3.5 allows -dump-bin to overwrite a local file. This has security relevance because, for example, execution of Dmidecode via Sudo is plausible. NOTE: Some third parties have indicated the fix in 3.5 does not adequately address the vulnerability. The argument is that the proposed patch prevents dmidecode from writing to an existing file. However, there are multiple attack vectors that would not require overwriting an existing file that would provide the same level of unauthorized privilege escalation (e.g. creating a new file in /etc/cron.hourly).
osv:DEBIAN-CVE-2023-30630
dmidecode
Fixed versions: Not specified
dmidecode
Fixed versions: 3.5-1
dmidecode
Fixed versions: 3.5-1
Complete source record
{
"id": "2bdbe0060fcd48a784fbba3a357d1e725393958a4cfb6f16cb00bf31f05f798b",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2023-30630",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2023-30630",
"summary": "Dmidecode before 3.5 allows -dump-bin to overwrite a local file. This has security relevance because, for example, execution of Dmidecode via Sudo is plausible. NOTE: Some third parties have indicated the fix in 3.5 does not adequately address the vulnerability. The argument is that the proposed patch prevents dmidecode from writing to an existing file. However, there are multiple attack vectors that would not require overwriting an existing file that would provide the same level of unauthorized privilege escalation (e.g. creating a new file in /etc/cron.hourly).",
"evidence": "osv:DEBIAN-CVE-2023-30630",
"products": [
{
"name": {
"value": "dmidecode",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "3.4-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.5-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.5-2",
"evidence": "/affected/0/versions"
},
{
"value": "3.5-3",
"evidence": "/affected/0/versions"
},
{
"value": "3.6-1",
"evidence": "/affected/0/versions"
},
{
"value": "3.6-2",
"evidence": "/affected/0/versions"
},
{
"value": "3.7-1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "dmidecode",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.5-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "dmidecode",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.5-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2023-30630",
"aliases": [
"DEBIAN-CVE-2023-30630"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "dmidecode",
"purl": "pkg:deb/debian/dmidecode?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"3.4-1",
"3.5-1",
"3.5-2",
"3.5-3",
"3.6-1",
"3.6-2",
"3.7-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-30630.json"
},
"ecosystem_specific": {
"urgency": "unimportant"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.5-1"
}
]
}
],
"package": {
"name": "dmidecode",
"purl": "pkg:deb/debian/dmidecode?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-30630.json"
},
"ecosystem_specific": {
"urgency": "unimportant"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.5-1"
}
]
}
],
"package": {
"name": "dmidecode",
"purl": "pkg:deb/debian/dmidecode?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-30630.json"
},
"ecosystem_specific": {
"urgency": "unimportant"
}
}
],
"modified": "2026-10-26T18:02:25.806001150Z",
"provider": "osv",
"upstream": [
"CVE-2023-30630"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2023-30630"
]
},
"related_cves": [
{
"value": "CVE-2023-30630",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 456017,
"published_at": "2023-04-13T16:15:07.93+00:00"
}