Audiobookshelf Vulnerable to Cross-Site-Scripting Reflected via POST Request in /api/upload
Audiobookshelf is a self-hosted audiobook and podcast server. Prior to version 2.21.0, an improper input handling vulnerability in the `/api/upload` endpoint allows an attacker to perform a reflected cross-site scripting (XSS) attack by submitting malicious payloads in the `libraryId` field. The unsanitized input is reflected in the server’s error message, enabling arbitrary JavaScript execution in a victim's browser. This issue has been patched in version 2.21.0.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-46338
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 5 Nov 2026, 03:27 UTC · Revision 1
Source evidence
Audiobookshelf Vulnerable to Cross-Site-Scripting Reflected via POST Request in /api/upload
core-osv · Original sourcePublished 29 Apr 2025, 04:34 UTC
Audiobookshelf is a self-hosted audiobook and podcast server. Prior to version 2.21.0, an improper input handling vulnerability in the `/api/upload` endpoint allows an attacker to perform a reflected cross-site scripting (XSS) attack by submitting malicious payloads in the `libraryId` field. The unsanitized input is reflected in the server’s error message, enabling arbitrary JavaScript execution in a victim's browser. This issue has been patched in version 2.21.0.
osv:CVE-2025-46338
Complete source record
{
"id": "0d0126e9cd7d38d6b4a9eba0f3f84c661d7ce9ce99c8b7fc0e8d7f41e1f52787",
"url": "https://osv.dev/vulnerability/CVE-2025-46338",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Audiobookshelf Vulnerable to Cross-Site-Scripting Reflected via POST Request in /api/upload",
"summary": "Audiobookshelf is a self-hosted audiobook and podcast server. Prior to version 2.21.0, an improper input handling vulnerability in the `/api/upload` endpoint allows an attacker to perform a reflected cross-site scripting (XSS) attack by submitting malicious payloads in the `libraryId` field. The unsanitized input is reflected in the server’s error message, enabling arbitrary JavaScript execution in a victim's browser. This issue has been patched in version 2.21.0.",
"evidence": "osv:CVE-2025-46338",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2025-46338",
"aliases": [
"CVE-2025-46338",
"GHSA-47g3-c5hx-2q3w"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/advplyr/audiobookshelf",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "fd84cd0d7f647705a49f300b9bdb940f9725e1a7"
},
{
"fixed": "35870a01583b2947030f4e3d4ac769c3ff298386"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:audiobookshelf:audiobookshelf:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.21.0"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "35870a01583b2947030f4e3d4ac769c3ff298386"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"v2.20.0",
"v2.19.5",
"v2.19.4",
"v2.19.3",
"v2.19.2",
"v2.19.1",
"v2.19.0",
"v2.18.1",
"v2.18.0",
"v2.17.7",
"v2.17.6",
"v2.17.5",
"v2.17.4",
"v2.17.3",
"v2.17.2",
"v2.17.1",
"v2.17.0",
"v2.16.1",
"v2.16.2",
"v2.16.0",
"v2.15.1",
"v2.15.0",
"v2.14.0",
"v2.13.4",
"v2.13.3",
"v2.13.2",
"v2.13.1",
"v2.13.0",
"v2.12.3",
"v2.12.2",
"v2.12.1",
"v2.12.0",
"v2.11.0",
"v2.10.1",
"v2.10.0",
"v2.9.0",
"v2.8.1",
"v2.8.0",
"v2.7.2",
"v2.7.1",
"v2.7.0",
"v2.6.0",
"v2.5.0",
"v2.4.4",
"v2.4.3",
"v2.4.2",
"v2.4.1",
"v2.4.0",
"v2.3.5",
"v2.3.4",
"v2.3.3",
"v2.3.2",
"v2.3.1",
"v2.3.0",
"v2.2.23",
"v2.2.22",
"v2.2.21",
"v2.2.20",
"v2.2.19",
"v2.2.18",
"v2.2.17",
"v2.2.15",
"v2.2.16",
"v2.2.14",
"v2.2.13",
"v2.2.12",
"v2.2.11",
"v2.2.10",
"v2.2.9",
"v2.2.8",
"v2.2.7",
"v2.2.6",
"v2.2.5",
"v2.2.4",
"v2.2.3",
"v2.2.2",
"v2.2.1",
"v2.2.0",
"v2.1.5",
"v2.1.4",
"v2.1.3",
"v2.1.2",
"v2.1.1",
"v2.1.0",
"v2.0.24",
"v2.0.23",
"v2.0.22",
"v2.0.21",
"v2.0.20",
"v2.0.19",
"v2.0.18",
"v2.0.17",
"v2.0.16",
"v2.0.15",
"v2.0.14",
"v2.0.13",
"v2.0.12",
"v2.0.11",
"v2.0.10",
"v2.0.9",
"v2.0.8",
"v2.0.7",
"v2.0.6",
"v2.0.5",
"v2.0.4",
"v2.0.3",
"v2.0.2",
"v2.0.1",
"v1.7.2",
"v1.7.1",
"v1.7.0",
"v1.6.0",
"v1.5.5",
"v1.5.0",
"v1.4.11",
"v1.4.9",
"v1.4.7",
"v1.4.6",
"v1.4.4",
"v1.4.2",
"v1.4.1",
"v1.4.0",
"v1.3.4",
"v1.3.3",
"v1.3.1",
"v1.2.8",
"v1.2.6",
"v1.2.5",
"v1.2.4",
"v1.2.1",
"v1.1.15",
"v1.1.14",
"v1.1.13",
"v1.1.12",
"v1.1.11",
"v1.1.10",
"v1.1.9",
"v1.1.8",
"v1.0.0",
"0.9.61-beta.0",
"0.9.61-beta"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-46338.json"
}
}
],
"modified": "2026-10-28T02:30:42.169481969Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/46xxx/CVE-2025-46338.json",
"https://github.com/advplyr/audiobookshelf/security/advisories/GHSA-47g3-c5hx-2q3w",
"https://nvd.nist.gov/vuln/detail/CVE-2025-46338",
"https://github.com/advplyr/audiobookshelf/commit/35870a01583b2947030f4e3d4ac769c3ff298386"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/46xxx/CVE-2025-46338.json"
}
},
"related_cves": [
{
"value": "CVE-2025-46338",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 509843,
"published_at": "2025-04-29T04:34:44.713+00:00"
}