Skip to content
Heist/ feed
Back to feed
High

rack-contrib vulnerable to Denial of Service due to the unconstrained value of the incoming "profiler_runs" parameter

Type: advisorySources: OSV

rack-contrib provides contributed rack middleware and utilities for Rack, a Ruby web server interface. Versions of rack-contrib prior to 2.5.0 are vulnerable to denial of service due to the fact that the user controlled data `profiler_runs` was not constrained to any limitation. This would lead to allocating resources on the server side with no limitation and a potential denial of service by remotely user-controlled data. Version 2.5.0 contains a patch for the issue.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2024-35231
Confirmed fixed CVEs
Not specified
Updated in this feed
3 Nov 2026, 08:22 UTC · Revision 1

Source evidence

rack-contrib vulnerable to Denial of Service due to the unconstrained value of the incoming "profiler_runs" parameter

core-osv · Original source

Published 27 May 2024, 16:40 UTC

rack-contrib provides contributed rack middleware and utilities for Rack, a Ruby web server interface. Versions of rack-contrib prior to 2.5.0 are vulnerable to denial of service due to the fact that the user controlled data `profiler_runs` was not constrained to any limitation. This would lead to allocating resources on the server side with no limitation and a potential denial of service by remotely user-controlled data. Version 2.5.0 contains a patch for the issue.

osv:CVE-2024-35231
Complete source record
{
  "id": "bfd5a840bd5017d1a027b1e28313fc521096cf4f770a1538ff2bcb96d527f54d",
  "url": "https://osv.dev/vulnerability/CVE-2024-35231",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "rack-contrib vulnerable to Denial of Service due to the unconstrained value of the incoming \"profiler_runs\" parameter",
    "summary": "rack-contrib provides contributed rack middleware and utilities for Rack, a Ruby web server interface. Versions of rack-contrib prior to 2.5.0 are vulnerable to denial of service due to the fact that the user controlled data `profiler_runs` was not constrained to any limitation. This would lead to allocating resources on the server side with no limitation and a potential denial of service by remotely user-controlled data. Version 2.5.0 contains a patch for the issue.",
    "evidence": "osv:CVE-2024-35231",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2024-35231",
      "aliases": [
        "CVE-2024-35231",
        "GHSA-8c8q-2xw3-j869"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/rack/rack-contrib",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "d5265bc4f849f4bf55b230d3a0929e513acd5fac"
                },
                {
                  "fixed": "0eec2a9836329051c6742549e65a94a4c24fe6f7"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "2.5.0"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StringRangeExpression"
                  },
                  {
                    "range": [
                      {
                        "fixed": "0eec2a9836329051c6742549e65a94a4c24fe6f7"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v2.4.0",
            "v2.3.0",
            "v2.2.0",
            "v2.1.0",
            "v2.0.1",
            "v2.0.0",
            "v1.8.0",
            "v1.7.0",
            "v1.6.0",
            "v1.5.0",
            "v1.4.0",
            "v1.3.0",
            "v1.2.0.39.g17d21b4",
            "v1.2.0",
            "1.1.0",
            "1.0.1",
            "0.9.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-35231.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:27.277164450Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/35xxx/CVE-2024-35231.json",
        "https://github.com/rack/rack-contrib/security/advisories/GHSA-8c8q-2xw3-j869",
        "https://nvd.nist.gov/vuln/detail/CVE-2024-35231",
        "https://github.com/rack/rack-contrib/commit/0eec2a9836329051c6742549e65a94a4c24fe6f7"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-770"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/35xxx/CVE-2024-35231.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2024-35231",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 493782,
  "published_at": "2024-05-27T16:40:08.678+00:00"
}