High
Security advisory
GStreamer before 1.16.0 has a heap-based buffer overflow in the RTSP connection parser via a crafted response from a server, potentially allowing remote code execution.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2019-9928
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 08:08 UTC · Revision 1
Source evidence
GStreamer before 1.16.0 has a heap-based buffer overflow in the RTSP connection parser via a crafted response from a server, potentially allowing remote code execution.
osv:CVE-2019-9928
Complete source record
{
"id": "d4bc8d2bd1d5f8724ce4864914c3a9bed077b2002b2040a80f0b673b2f7d4793",
"url": "https://osv.dev/vulnerability/CVE-2019-9928",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2019-9928",
"summary": "GStreamer before 1.16.0 has a heap-based buffer overflow in the RTSP connection parser via a crafted response from a server, potentially allowing remote code execution.",
"evidence": "osv:CVE-2019-9928",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2019-9928",
"aliases": [
"CVE-2019-9928"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/gstreamer/gstreamer",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "2c3480796a6673c638f5b12c7bdf5c0f191120fd"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:gstreamer:gstreamer:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.16.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"gstreamer-vaapi-1.15.90",
"gstreamer-vaapi-1.15.2",
"gstreamer-vaapi-1.15.1",
"gstreamer-vaapi-1.14.0",
"gstreamer-vaapi-1.13.91",
"gstreamer-vaapi-1.13.90",
"gstreamer-vaapi-1.13.1",
"gstreamer-vaapi-1.12.0",
"gstreamer-vaapi-1.11.91",
"gstreamer-vaapi-1.11.90",
"gstreamer-vaapi-1.11.2",
"gstreamer-vaapi-1.11.1",
"gstreamer-vaapi-1.10.0",
"gstreamer-vaapi-1.11.0",
"gstreamer-vaapi-1.9.90",
"gstreamer-vaapi-1.9.2",
"gstreamer-vaapi-1.9.1",
"gstreamer-vaapi-1.8.0",
"gstreamer-vaapi-1.7.91",
"gstreamer-vaapi-1.7.90",
"gstreamer-vaapi-1.6.0",
"gstreamer-vaapi-0.7.0",
"gstreamer-vaapi-0.6.0",
"gstreamer-vaapi-0.5.10"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-9928.json"
}
}
],
"modified": "2026-10-24T10:31:03.504947108Z",
"provider": "osv",
"references": [
"https://gstreamer.freedesktop.org/security/",
"https://gstreamer.freedesktop.org/security/sa-2019-0001.html",
"https://lists.debian.org/debian-lts-announce/2019/04/msg00030.html",
"https://lists.debian.org/debian-lts-announce/2019/04/msg00031.html",
"https://seclists.org/bugtraq/2019/Apr/39",
"https://security.gentoo.org/glsa/202003-33",
"https://usn.ubuntu.com/3958-1/",
"https://www.debian.org/security/2019/dsa-4437"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:*",
"cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:*",
"cpe:2.3:o:canonical:ubuntu_linux:18.10:*:*:*:*:*:*:*"
],
"vendor_product": "canonical:ubuntu_linux",
"extracted_events": [
{
"range": [
{
"introduced": "16.04"
},
{
"last_affected": "16.04"
},
{
"introduced": "18.04"
},
{
"last_affected": "18.04"
},
{
"introduced": "18.10"
},
{
"last_affected": "18.10"
}
],
"source": "CPE_STRING"
}
]
},
{
"cpes": [
"cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*",
"cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*"
],
"vendor_product": "debian:debian_linux",
"extracted_events": [
{
"range": [
{
"introduced": "8.0"
},
{
"last_affected": "8.0"
},
{
"introduced": "9.0"
},
{
"last_affected": "9.0"
}
],
"source": "CPE_STRING"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2019-9928",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 440268,
"published_at": "2019-04-24T15:29:02.293+00:00"
}