node-mermaid — security advisory
Mermaid is a JavaScript based diagramming and charting tool that uses Markdown-inspired text definitions and a renderer to create and modify complex diagrams. In the default configuration of mermaid 11.9.0 and earlier, user supplied input for architecture diagram icons is passed to the d3 html() method, creating a sink for cross site scripting. This vulnerability is fixed in 11.10.0.
- Products
- node-mermaid
- Affected versions
- 8.13.3+ds+~cs26.13.21-1, 8.13.3+ds+~cs26.13.21-2, 8.13.8+~cs10.4.16-1, 8.7.0+ds+~cs27.17.17-3, 9.2.2+~2.0.0-1, 9.2.2+~2.0.0-2
- Fixed versions
- Not specified
- CVEs
- CVE-2025-54880
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 01:33 UTC · Revision 1
Source evidence
Mermaid is a JavaScript based diagramming and charting tool that uses Markdown-inspired text definitions and a renderer to create and modify complex diagrams. In the default configuration of mermaid 11.9.0 and earlier, user supplied input for architecture diagram icons is passed to the d3 html() method, creating a sink for cross site scripting. This vulnerability is fixed in 11.10.0.
osv:UBUNTU-CVE-2025-54880
node-mermaid
Fixed versions: Not specified
node-mermaid
Fixed versions: Not specified
Complete source record
{
"id": "63b1c347f3308b3910b3c392d032004525fc6dc8f4cd1e17b99302b591654b9c",
"url": "https://osv.dev/vulnerability/UBUNTU-CVE-2025-54880",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "UBUNTU-CVE-2025-54880",
"summary": "Mermaid is a JavaScript based diagramming and charting tool that uses Markdown-inspired text definitions and a renderer to create and modify complex diagrams. In the default configuration of mermaid 11.9.0 and earlier, user supplied input for architecture diagram icons is passed to the d3 html() method, creating a sink for cross site scripting. This vulnerability is fixed in 11.10.0.",
"evidence": "osv:UBUNTU-CVE-2025-54880",
"products": [
{
"name": {
"value": "node-mermaid",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "8.7.0+ds+~cs27.17.17-3",
"evidence": "/affected/0/versions"
},
{
"value": "8.13.3+ds+~cs26.13.21-1",
"evidence": "/affected/0/versions"
},
{
"value": "8.13.3+ds+~cs26.13.21-2",
"evidence": "/affected/0/versions"
},
{
"value": "8.13.8+~cs10.4.16-1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "node-mermaid",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "9.2.2+~2.0.0-1",
"evidence": "/affected/1/versions"
},
{
"value": "9.2.2+~2.0.0-2",
"evidence": "/affected/1/versions"
}
]
}
],
"severity": "medium",
"structured": {
"id": "UBUNTU-CVE-2025-54880",
"aliases": [
"UBUNTU-CVE-2025-54880"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N"
},
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
},
{
"type": "Ubuntu",
"score": "medium"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "node-mermaid",
"purl": "pkg:deb/ubuntu/node-mermaid?arch=source&distro=jammy",
"ecosystem": "Ubuntu:22.04:LTS"
},
"versions": [
"8.7.0+ds+~cs27.17.17-3",
"8.13.3+ds+~cs26.13.21-1",
"8.13.3+ds+~cs26.13.21-2",
"8.13.8+~cs10.4.16-1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2025/UBUNTU-CVE-2025-54880.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "node-mermaid",
"binary_version": "8.13.8+~cs10.4.16-1"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "node-mermaid",
"purl": "pkg:deb/ubuntu/node-mermaid?arch=source&distro=stonking",
"ecosystem": "Ubuntu:26.10"
},
"versions": [
"9.2.2+~2.0.0-1",
"9.2.2+~2.0.0-2"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2025/UBUNTU-CVE-2025-54880.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "node-mermaid",
"binary_version": "9.2.2+~2.0.0-2"
}
]
}
}
],
"modified": "2026-10-17T12:57:08.391924084Z",
"provider": "osv",
"upstream": [
"CVE-2025-54880"
],
"references": [
"https://ubuntu.com/security/CVE-2025-54880",
"https://www.cve.org/CVERecord?id=CVE-2025-54880",
"https://github.com/mermaid-js/mermaid/security/advisories/GHSA-8gwm-58g9-j8pw",
"https://github.com/mermaid-js/mermaid/commit/2aa83302795183ea5c65caec3da1edd6cb4791fc",
"https://github.com/mermaid-js/mermaid/commit/734bde38777c9190a5a72e96421c83424442d4e4"
]
},
"related_cves": [
{
"value": "CVE-2025-54880",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/1/score"
},
"source_id": "core-osv",
"document_id": 356771,
"published_at": "2025-08-19T17:15:00+00:00"
}