Medium
WordPress Royal Elementor Addons plugin <= 1.7.1069 - Cross Site Scripting (XSS) vulnerability
Type: advisorySources: Official CVE List
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WProyal Royal Elementor Addons royal-elementor-addons allows DOM-Based XSS.This issue affects Royal Elementor Addons: from n/a through 1.7.1069.
- Products
- Royal Elementor Addons
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-112865
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 00:50 UTC · Revision 1
Source evidence
WordPress Royal Elementor Addons plugin <= 1.7.1069 - Cross Site Scripting (XSS) vulnerability
core-cve · Original sourcePublished 26 Oct 2026, 10:01 UTC
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WProyal Royal Elementor Addons royal-elementor-addons allows DOM-Based XSS.This issue affects Royal Elementor Addons: from n/a through 1.7.1069.
cve:CVE-2026-112865
Royal Elementor Addons
Fixed versions: Not specified
Complete source record
{
"id": "4554cc6a10dccd5b2dad04eedb18ab3b124aebedcc71d0075dadfa8f8e31542e",
"url": "https://www.cve.org/CVERecord?id=CVE-2026-112865",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "WordPress Royal Elementor Addons plugin <= 1.7.1069 - Cross Site Scripting (XSS) vulnerability",
"summary": "Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WProyal Royal Elementor Addons royal-elementor-addons allows DOM-Based XSS.This issue affects Royal Elementor Addons: from n/a through 1.7.1069.",
"evidence": "cve:CVE-2026-112865",
"products": [
{
"name": {
"value": "Royal Elementor Addons",
"evidence": "/containers/cna/affected/0/product"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": []
}
],
"severity": "medium",
"structured": {
"id": "CVE-2026-112865",
"aliases": [
"CVE-2026-112865"
],
"metrics": [
{
"format": "CVSS",
"cvssV3_1": {
"scope": "CHANGED",
"version": "3.1",
"baseScore": 6.5,
"attackVector": "NETWORK",
"baseSeverity": "MEDIUM",
"vectorString": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L",
"integrityImpact": "LOW",
"userInteraction": "REQUIRED",
"attackComplexity": "LOW",
"availabilityImpact": "LOW",
"privilegesRequired": "LOW",
"confidentialityImpact": "LOW"
},
"scenarios": [
{
"lang": "en",
"value": "GENERAL"
}
]
}
],
"affected": [
{
"vendor": "WProyal",
"product": "Royal Elementor Addons",
"versions": [
{
"status": "affected",
"changes": [
{
"at": "1.7.1070",
"status": "unaffected"
}
],
"version": "0",
"versionType": "custom",
"lessThanOrEqual": "1.7.1069"
}
],
"packageName": "royal-elementor-addons",
"collectionURL": "https://wordpress.org/plugins",
"defaultStatus": "unaffected"
}
],
"modified": "2026-10-26T10:23:41.001Z",
"provider": "cve",
"references": [
"https://patchstack.com/database/wordpress/plugin/royal-elementor-addons/vulnerability/wordpress-royal-elementor-addons-plugin-1-7-1069-cross-site-scripting-xss-vulnerability?_s_id=cve"
],
"provider_metadata": {
"adp": [
{
"title": "CISA ADP Vulnrichment",
"metrics": [
{
"other": {
"type": "ssvc",
"content": {
"id": "CVE-2026-112865",
"role": "CISA Coordinator",
"options": [
{
"Exploitation": "none"
},
{
"Automatable": "no"
},
{
"Technical Impact": "partial"
}
],
"version": "2.0.3",
"timestamp": "2026-10-26T10:13:22.366071Z"
}
}
}
],
"providerMetadata": {
"orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0",
"shortName": "CISA-ADP",
"dateUpdated": "2026-10-26T10:23:41.001Z"
}
}
],
"cna": {
"orgId": "21595511-bba5-4825-b968-b78d1f9984a3",
"shortName": "Patchstack",
"dateUpdated": "2026-10-26T10:02:04.875Z"
}
}
},
"related_cves": [
{
"value": "CVE-2026-112865",
"evidence": "/cveMetadata/cveId"
}
],
"security_relevant": true,
"severity_evidence": "/containers/cna/metrics"
},
"source_id": "core-cve",
"document_id": 283276,
"published_at": "2026-10-26T10:01:03.255+00:00"
}