jquery-validation ReDoS in url2 due to incomplete fix of CVE-2021-43306
The jQuery Validation Plugin (jquery-validation) provides drop-in validation for forms. Versions of jquery-validation prior to 1.19.5 are vulnerable to regular expression denial of service (ReDoS) when an attacker is able to supply arbitrary input to the url2 method. This is due to an incomplete fix for CVE-2021-43306. Users should upgrade to version 1.19.5 to receive a patch.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-31147
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 17:03 UTC · Revision 1
Source evidence
jquery-validation ReDoS in url2 due to incomplete fix of CVE-2021-43306
core-osv · Original sourcePublished 14 Jul 2022, 19:30 UTC
The jQuery Validation Plugin (jquery-validation) provides drop-in validation for forms. Versions of jquery-validation prior to 1.19.5 are vulnerable to regular expression denial of service (ReDoS) when an attacker is able to supply arbitrary input to the url2 method. This is due to an incomplete fix for CVE-2021-43306. Users should upgrade to version 1.19.5 to receive a patch.
osv:CVE-2022-31147
Complete source record
{
"id": "bebcf216587442071766994e04c69956c7d23d0ac5209c5e9c732e5afed1666c",
"url": "https://osv.dev/vulnerability/CVE-2022-31147",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "jquery-validation ReDoS in url2 due to incomplete fix of CVE-2021-43306",
"summary": "The jQuery Validation Plugin (jquery-validation) provides drop-in validation for forms. Versions of jquery-validation prior to 1.19.5 are vulnerable to regular expression denial of service (ReDoS) when an attacker is able to supply arbitrary input to the url2 method. This is due to an incomplete fix for CVE-2021-43306. Users should upgrade to version 1.19.5 to receive a patch.",
"evidence": "osv:CVE-2022-31147",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2022-31147",
"aliases": [
"CVE-2022-31147",
"GHSA-ffmh-x56j-9rc3"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/jquery-validation/jquery-validation",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "5907740ce2492338606dbbdbd13d244a8d545097"
},
{
"fixed": "5bbd80d27fc6b607d2f7f106c89522051a9fb0dd"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:jqueryvalidation:jquery_validation:*:*:*:*:*:node.js:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.19.5"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "5bbd80d27fc6b607d2f7f106c89522051a9fb0dd"
}
],
"source": "REFERENCES_COMMIT"
},
{
"range": [
{
"fixed": "5907740ce2492338606dbbdbd13d244a8d545097"
}
],
"source": "REFERENCES_TAG",
"original_tag": "1.19.5"
}
]
}
}
],
"versions": [
"1.11.1",
"1.11.0",
"1.10.0",
"1.9.0",
"1.8.1",
"1.8.0",
"1.8.0pre",
"1.7.0",
"1.6.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-31147.json"
}
}
],
"modified": "2026-10-28T02:30:37.771213643Z",
"provider": "osv",
"references": [
"https://github.com/jquery-validation/jquery-validation/releases/tag/1.19.5",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/31xxx/CVE-2022-31147.json",
"https://github.com/jquery-validation/jquery-validation/security/advisories/GHSA-ffmh-x56j-9rc3",
"https://nvd.nist.gov/vuln/detail/CVE-2022-31147",
"https://github.com/jquery-validation/jquery-validation/commit/5bbd80d27fc6b607d2f7f106c89522051a9fb0dd"
],
"provider_metadata": {
"cwe_ids": [
"CWE-1333"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/31xxx/CVE-2022-31147.json"
}
},
"related_cves": [
{
"value": "CVE-2022-31147",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 505113,
"published_at": "2022-07-14T19:30:14+00:00"
}