HighFix available
ruby-git — security advisory
ruby-git versions prior to v1.13.0 allows a remote authenticated attacker to execute an arbitrary ruby code by having a user to load a repository containing a specially crafted filename to the product. This vulnerability is different from CVE-2022-46648.
- Products
- ruby-git
- Affected versions
- Not specified
- Fixed versions
- 1.13.1-1
- CVEs
- CVE-2022-47318
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 15:03 UTC · Revision 1
Source evidence
ruby-git versions prior to v1.13.0 allows a remote authenticated attacker to execute an arbitrary ruby code by having a user to load a repository containing a specially crafted filename to the product. This vulnerability is different from CVE-2022-46648.
osv:DEBIAN-CVE-2022-47318
ruby-git
Fixed versions: 1.13.1-1
ruby-git
Fixed versions: 1.13.1-1
ruby-git
Fixed versions: 1.13.1-1
Complete source record
{
"id": "5a8d179fdd4484a77decf1546662d63a8c26267ab7a34e4b500846b606f5befe",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-47318",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2022-47318",
"summary": "ruby-git versions prior to v1.13.0 allows a remote authenticated attacker to execute an arbitrary ruby code by having a user to load a repository containing a specially crafted filename to the product. This vulnerability is different from CVE-2022-46648.",
"evidence": "osv:DEBIAN-CVE-2022-47318",
"products": [
{
"name": {
"value": "ruby-git",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.13.1-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "ruby-git",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.13.1-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "ruby-git",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.13.1-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2022-47318",
"aliases": [
"DEBIAN-CVE-2022-47318"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.13.1-1"
}
]
}
],
"package": {
"name": "ruby-git",
"purl": "pkg:deb/debian/ruby-git?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-47318.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.13.1-1"
}
]
}
],
"package": {
"name": "ruby-git",
"purl": "pkg:deb/debian/ruby-git?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-47318.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.13.1-1"
}
]
}
],
"package": {
"name": "ruby-git",
"purl": "pkg:deb/debian/ruby-git?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-47318.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-15T08:02:46.737992927Z",
"provider": "osv",
"upstream": [
"CVE-2022-47318"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2022-47318"
]
},
"related_cves": [
{
"value": "CVE-2022-47318",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 324218,
"published_at": "2023-01-17T10:15:11.25+00:00"
}